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What is BIM ? 
Building Information Modelling 

BIM is an acronym for Building Information Modelling.  The term was popularized by 

Jerry Laiserin as a common name for a digital representation of the building process to 

facilitate exchange and interoperability of information in digital format. According to him 

and others, the first implementation of BIM was under the Virtual Building concept by 

Graphisoft in 1987 with ArchiCAD 3.1 

 

Early on the term BIM was used to distinguish the information rich architectural 3D 

modelling from the traditional 2D drawing. Over the last 25 years other software vendors 

have created BIM style solutions and to differing degrees, they all make a reliable digital 

representation of the building available for design decision making, high-quality 

construction document production, construction planning, performance predictions, and 

cost estimates.  

 

Having the ability to keep information up-to-date and accessible in an integrated digital 

environment gives architects, engineers, builders, and owners a clear overall vision of all 

their projects, as well as the ability to make informed decisions faster.  

 

The use of the term BIM has become widespread and has started to evolve.  BIM still 

refers to Building Information Modelling, but now also includes the coordination of these 

highly descriptive Models within the AEC industry (Architecture, Engineering and 

Construction).  More than ever we now see Architectural models being used as the basis 

for the Structural Analysis models or as the skeleton with which the MEP designers fit 

their Mechanical, Electrical and Plumbing components.  Equally the Structural Model or 

the MEP model can be brought into the Architectural model and the resultant model can 

be checked for clashes. Furthermore these models can be used for cost analysis, 

environmental impact and many others. 

 

Customers using BIM will save time and money, see fewer design errors, experience 

improved productivity, and have access to new business opportunities. BIM is not a 

technology, but it does require suitable technology to be implemented effectively.  

Graphisoft has made the coordination process achievable with integrated solutions for 

MEP and Energy Analysis and has the ability to export of the model in IFC format which 

is becoming the industry standard for sharing the models data. 

ArchiCAD Tutorials 

 

GRAPHISOFT have created a simple & easy to follow Training Series that help users 

learn by doing; with files, documents & videos. These training modules are intended to 

expand your ArchiCAD knowledge in broad range of topics. 

 

The ArchiCAD Tutorials are available to download from 

http://www.graphisoft.com/learning/training_materials/ and are available for both 

Windows and Macintosh platforms. 

 

 

 

Once you have the ArchiCAD files, you simply open ArchiCAD’s YouTube channel from 

within the ArchiCAD > Help menu, watch the related movie clip and follow the 

instructions, whilst you have the relevant download file open.  The clips can of course be 

paused, rewound and replayed. 

These include Mies Van Der Rohes Farnsworth House to bespoke houses and large 

apartment complexes to accommodate for all skill levels. 

 

 

http://en.wikipedia.org/wiki/Graphisoft
http://en.wikipedia.org/wiki/1987
http://www.graphisoft.com/learning/training_materials/
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There are also a series of Interactive Training Guides available: 

 

 Experience BIM  - Using the Frank Lloyd Wright designed Massaro 

House, this provides a conceptual overview of Building Information Modelling 

 ArchiCAD Essentials  - Designing and documenting an office building from 

scratch, this provides in-depth insight into the functions and working methods of 

a BIM application  

 ArchiCAD Collaboration Part 1 (ArchiCAD Teamwork) – a step-by-step 

introduction to ArchiCAD's Teamwork concept. 

 ArchiCAD Collaboration Part 2 (Collaboration Techniques) - an overview of 

collaboration techniques between ArchiCAD and various other programs. 

 Advanced Modelling  – an introductory guide to advanced modelling 

techniques for creating complex forms and structures. 

 

“The core of this material is the Experience BIM module which won the 2008 

International Stevie Award for Best Training Technology and was a  finalist in the 2008 

Codie Award for Best Workforce Training Solution”, said Akos Pfemeter, Director of 

Marketing. “There is no other BIM learning resource in our industry that has been so 

highly commended.”  

 

ArchiCAD Help 

The built-in Help within ArchiCAD is much more than just linking to a printed HTML 

document.  Whenever you hit an ArchiCAD help icon you are taken to the online 

interactive Help (provided you have an internet connection), where you can see the text 

document, as well as movie clips and any related web content. 

 

 

ArchiCAD YouTube Channel 

GRAPHISOFT’s ArchiCAD YouTube Channel is not just for your ArchiCAD Tutorial 

movie clips.  There are hundreds of short clips on all aspect of ArchiCAD from New 

Features to specific modelling senarios. 

 

You can access it direct from ArchiCAD from the Help > ArchiCAD YouTube Channel 

menu or simply use you Internet Browser http://www.youtube.com/user/Archicad  

 

 

 

 
 
 
  

http://www.youtube.com/user/Archicad
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About this Book 
This book contains all the exercises used in the 3 Day Introduction to ArchiCAD. 

The exercises take you through ArchiCAD and introduce you to the concept of Virtual 

Building (aka Building Information Modelling.) 

The exercises in the book switch between simple exercises and a project to produce 

some drawings for a single story bach. 

ArchiCAD Files exist for each step so that you can practice any module you choose. 

If you work through the book from start-to-finish you should be able to work with a single 

file throughout the bach building exercise. 

Formatting Conventions 

This book makes use of the following formatting conventions: 

ArchiCAD Menus 

ArchiCAD Menu commands are referenced using the full path separated with ‘>’  

For example: Edit > Select All refers to the Select All command found under the Edit 

menu. 

Menu Commands that open a dialog box end with an ‘…’ 

For Example: File > Save As… refers to the Save As Dialog in the File Menu. 

ArchiCAD Elements 

All ArchiCAD elements are referred to using capital letters. 

For example: Wall, Door, Slab etc 

ArchiCAD Files 

All Files are provided on the Desktop of your Training Computer and can be copied to a 

personal USB to be used by yourself in future. 

 

 

 

 

 

Important Notes: 

This book has been written based on the Training 19 Template File and assumes the 

Work Environment is set to the Cadimage Profile 19.  

Using a different profile will mean that commands are not necessarily located in the 

same place / menu. 

 

BIM Notes: 

Where relevant, we will add a short note on how this relates to the bigger 

picture of Building Information Modelling (BIM). 
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Module 1 – Introduction 
This module introduces you to ArchiCAD. It takes you through the basic ArchiCAD Set Up 
along with some important concepts including: 

Interface 

Navigating 

Tools 

Settings 

Favorites 

The ArchiCAD Interface 

File: Finished Bach.PLN 

Familiarise yourself with the following Interface Elements: 

 Menu 

 Toolbar 

 Toolbox 

 Info Box 

 Navigator 

 Quick Options 

Navigating 

The Navigator allows you to access all parts of the Virtual 

Building. The Navigator has four modes: 

 Project Map 

 View Map 

 Layout Book 

 Publisher 

File types  

 .pln is the 

ArchiCAD file this 

contains all of the 

project information, 

model & drawing. 

 .bpn is the backup ArchiCAD file (with the red arrow) 

Explore the Virtual Building with the Navigator 

 Select the Project Map 
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 Double Click the Stories 

 

 Double Click the Sections 

 

 Double Click the 4 Elevations 

 

 Double Click the 3D Generic viewpoints 

 

 

 

 Switch to the View Map 

 

 Click through the different Views 

 

 Switch to the Layout Book 

 

 Click through the different Layouts 
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ArchiCAD Tools, Settings & Favorites 

All Tools are controlled via a Settings Dialog 

 Open the Wall Settings by double-clicking on the Wall Tool in the Tool Box 

 Explore the Settings 

 

 

 Click OK 

 Open the Slab Settings by double-clicking on the Slab Tool 

 Explore the Settings 

 

 

 Click OK 

 

 

 

 



INTRODUCTION TO BIM   

Introduction to BIM   Page 9 of 166 

As you will see there is a large array of settings to set. Once you have configured an 

element (eg a Wall) and you want to remember the settings you can use Favorites 

 

 Open the Column Default Settings (you can use Ctrl+T or ⌘+T if you have the 

Column Tool selected) 

 Click the Favorites button 

 

 

 

 Select the 250UC NZE Favorite 

 Hit Apply. Notice the Column Settings change 

 

 Re-open Favorites 

 Notice this is where you save a Favorite as well 

Important Concepts 

In these Exercises we will look at the basic concepts of placing and manipulating objects 

within the BIM. 

 Open the Day 1 Concepts.PLN file. 

 File > Open > Open then Browse for the folder on your Desktop called AC19 

BIM Intro; select ‘Day 1 Concepts’ file. 

 In the Navigator set to show the View Map, double click on Exercise 1. 

 Your tutor will take you through each of the exercises/stories within this view.  

 If you find them too easy and have finished quickly go to the next view and 

complete the exercises. 

 

 

 

 Continue down the saved views 

 until you get to Exercise 8. 
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Exercise 1 

This exercise shows you the various methods of placing a Wall and the use of 

Guidelines and the Tracker.  It is also relevant to placing any object that has a length. 

 

 

 

 

Exercise 2 

This exercise shows you how to TRIM using Ctrl (PC) or Command (Mac) and the 

Scissors icon 
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Exercise 3 

This exercise shows you how to PICK UP parameters using Alt (PC) or Alt/Option (Mac) 

and TRANSFER parameters using Alt+Ctrl (PC) or Alt/Option+Command (Mac) 

 PICK UP   TRANSFER 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 4 

This exercise shows you how to Extend and SPLIT using Ctrl (PC) or Command (Mac). 

Alternatively we can use the dedicated Split, Adjust and Intersect Tools. 

 SPLIT   ADJUST   INTERSECT 

 

 

 



    INTRODUCTION TO BIM 

Page 12 of 166                Introduction to BIM    

Exercise 5 

This exercise shows you the differences between Nodes and Edges on Polygons 

shapes (Slabs, Fills, Roofs, Zones, Meshes etc) 

 

 

 

 

 

Exercise 6 

This exercise shows you how to Drag, Rotate, Split, Multiply, make Roofs meet using 

Ctrl click (PC) or Command click (Mac) (and cleanly intersect in 3D) and fill areas with 

polygon surfaces (Fills, Slabs, Roofs etc) using the Magic Wand. 
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Exercise 7 

This exercise applies the skills learned into practical building tasks.  Trim, Extend, 

Intersect, Drag, Drag a Copy and Multiply.  

 

 

 

 

Exercise 8 

This exercise shows you some of the different ArchiCAD Cursors (Perpendicular, 

Parallel, Bi-sector) along with Snap Guides and Guide Lines.  
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ArchiCAD Intelligent Cursor  

When using ArchiCAD, the intelligent cursor takes on various shapes in different 

locations and situations in the project.  

These pages describes each icon and when it would appear. 

 

    Icon Name: 

 

  Arrow: empty area on the workspace (when Arrow Tool is active) 

 

Crosshair: empty area on the workspace (when a Design or 

Documentation Tool is active) 

 

Quick Selection using Arrow tool: appears whenever you move the 

cursor onto a quick-selectable item 

 

Arrow with Heavy Checkmark: snapping to nodes on Reference 

Lines of walls 

 

Arrow with Light Checkmark: snapping to nodes other than the ones 

on Reference Lines 

 

Heavy Checkmark: snapping to nodes on Reference Lines of walls 

and reference axes of beams  

 

Light Checkmark: snapping at any other hotspot of any element. 

 

Arrow with Heavy Mercedes: snapping to Reference Lines 

 

Arrow with Light Mercedes: snapping to edges other than Reference 

Lines 

Heavy Mercedes: snapping to Reference Lines 

 

Light Mercedes: snapping to edges other than Reference Lines 

 

Arrow with Intersection: snapping to an intersection of edges 

 

Intersection: snapping at an intersection of edges 

 

Arrow with Perpendicular sign: snapping perpendicularly to an edge 

or arc while dragging an element 

 

Arrow with Tangent sign: snapping tangentially to an arc while 

 dragging an element 

    

Cloud: indicates empty space over the horizon in perspective views 

 

Cursors Used Only while Drafting and Editing: 

 

White/Empty pencil: in an empty space or over any element where 

 there is no hotspot or edge 

 

Striped pencil: snapping to edges 

 

Striped pencil with black top: snapping to Reference Lines and 

 reference axes 

Filled pencil: snapping to nodes on Reference Lines and reference 

 axes 

 

Filled pencil with white top: snapping to any other node or hotspot  
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Pencil point with intersection: snapping at an intersection of edges  

 

Pencil point with perpendicular sign: snapping at a perpendicular 

 edge 

 

Pencil point with tangent sign: snapping at a tangential edge 

 

Scissors: trims elements hold down the Ctrl/Command key while 

clicking on an element 

 

1) White Scissors: indicates empty space or on node. Not 

positioned properly to trim 
2) Black Scissors: appear on top of element edges. Click to trim 

the element 

 

Magic Wand on Empty space:  used for tracing the contours of 

existing elements for creating new elements with the active tool  

 

Magic Wand on the identifying node: uses the active tool to trace an 

edge 

 

Magic Wand on the identifying edge: uses the active tool to trace an 

edge 

 

Empty Eyedropper/Syringe: empty area in the workspace when 

transferring element settings 

 

Empty Eyedropper/Syringe with stripe: snapping to edges when 

transferring element settings 

 

Half filled Eyedropper/Syringe: snapping to hotspots and general 

nodes when transferring element settings 

 

Full Eyedropper/Syringe: snapping to nodes on Reference Lines 

and reference axes when transferring 

Element settings 

 

Eyeball: defines the direction of  

1) Roof: Once the pivot line drawn, click to indicate upward slope of 

roof 

2) Section/Elevation: click to define the direction of section or 

elevation and depth of view 

3) Doors: click to define hinge side and swing direction  

4) Windows: Click to define exterior side 

5) After Splitting Elements: Click on one side of the split to indicate 

which elements will remain selected 

 

Double Eyeball: locates position of edge-placed Door/Window  

 

Hammer: places Dimension chains, Angular Dimensions, the Elevation 

Dimension array, Zone Stamps and Fill areas; it also appears when 

closing polygons 

 

Trident: Moves marquee area or the Clipboard contents after pasting 

 

Plus: when dragging, rotating or mirroring a copy of an element 

  

Double-Plus: when dragging or rotating multiple copies of an element. 

  

Fill Handle: prompts you to draw a vector orientation after a fill is 
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Module 2 – Project Setup 
In this module you will setup your initial project.  You will learn the following principles: 

 

 Starting a Project from a Template 

 Adding Project Data 

 Setting up Story Levels 

 

Start new Project 

 To begin the Bach you need to start a new file using a Template 

 

A template file is basically our default start point.  It has the look and feel of our 

Documentation; Title Blocks, text, dimension and marker styles, and potentially is filled 

with office standard data, favourite walls, Roofs, Furniture etc.  For the purposes of this 

Training course we have stripped out most of the Standard Template automation, in order 

for you to learn how to create this yourselves. 

 

 Select File > New… 

 Make sure you select the Training 19.tpl template and you have set your work 

environment to Cadimage Profile 19 and click New 

 Before going any further it is a good idea to save your file. Select File > Save 

As… and save the file as My New Bach (make sure the file type is set to save 

as a PLN)  

 

 

 

 

 While working it is a good idea to get in the habit of saving frequently, you can 

use the Ctrl+S / Command+S shortcut key to save your file. 
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Add Project Data 

Before modelling anything you can add all the information about the project into Project 

Info. 

This is information like for example; Clients details, Site details, your Company details, 

Consultants details if applicable etc etc. 

This information can be automatically used later in our Title Blocks etc. 

 Go to File > Info > Project Info 

 Within PROJECT & SITE DETAILS set: 

 Project Name = My New Bach 

 Project Number = 2013-227 

 Project Status = CONCEPT DESIGN 

 Within CLIENT DETAILS set: 

 Client Name = Mr & Mrs Client 

 

Hit OK 

We’ll come back to use this later in the course. 

Setting up Story Levels 

Story Levels are the horizontal levels that ArchiCAD uses, generally these are the 

building floors.  But we set aside a separate level for the Site. 

The Stories are labelled Story 0, Story 1, Story 2 etc. 

 

In a standard single story residence, we would create 3 stories. 

 Story 0 = Datum or Sea Level (this is where we model the Site terrain) 

 Story 1 = Ground floor 

 Story 2 = Roof 

 

In a 4 level office building with 1 level of underground parking we would create: 

 Story 0 = Datum 

 Story 1 = Lowest modelled floor i.e. lower basement 1 

 Story 2 = Ground Floor 

 Story 3 = First Floor 

 Story 4 = Second Floor 

 Story 5 = Third Floor 

 Story 6 = Roof 

 

We are modelling a single story Bach. 

 Go to Design > Story Settings 

 By default we see 3 stories – these are fine for our purposes 

 

 

 



    INTRODUCTION TO BIM 

Page 18 of 166                Introduction to BIM    

Note that Sea Level & Ground Floor both have an R.L. of 0.000.  This is typical as the 

standard scenario of residential construction is; 

 Client engages Designer 

 Client & Designer discuss brief & examine Site 

 Designer start preliminary Concept and engages Surveyor on Clients behalf 

 1-2 weeks later Site Survey arrives 

 Survey data is brought into ArchiCAD 

 Building is placed correctly on Site. 

 

With Sea Level and Ground Floor both set to 0.000 its as easy as adding the new R.L. 

into the Height to Next field and all the modelled elements move to the correct location. 

 

We will do this after we add the terrain later in the course. 

 

Module 3 – Bach Beginnings 
In this module you will model your basic building.  You will create the following elements: 

 

Exterior Walls  Floor Slab      Interior Walls  Roof 

BIM Note: 

As we are modelling in 3D, we need to think about more than simply the 

length of our wall.  What is its height and thickness, this will allow us to get 

Volume information later on, what is its Surface finish; paint on the interior & 

weatherboards on the exterior, etc. 

 

In the early stages of the design model you could simply model the structural 

elements; Wall framing (excluding linings and/or claddings), Floor structure 

(with slab on grade don’t model hardcore fill, sand blinding etc) & with Roofs 

just model the top chord or the rafter thickness.  

 

With the new Priority Based Junctions, even the initial concept can be done 

with finishes on, and let ArchiCAD clean up all the element connections.  

Which we will do! 

 

Exterior Walls 

 Ensure you are currently on the Ground Floor Story 

 Open the Wall Settings and set up a Wall with the following key settings: 

 

 Save a Favorite called Exterior Walls 1 before you click OK 
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 Make sure you are set to draw a rectangular set of Walls & Core Outside 

 

 

 

 Click the Hotspot to indicate the 

starting point and then draw a set of 

Walls that are 10800mm by 5400mm 

(Using the Tracker, Type 10800, then 

Tab, then 5400, then Enter) 

 

 The next set of Walls overlap with the 

first so we need to set up some guide 

lines. 

 The overlap of the two forms is 

1800mm so drag a guide line onto the 

East and South Walls. 

 Use the orange dots to drag these 

guidelines to form the intersection.  

 One Guide Line 1800mm to the left of 

the top right corner 

 And another Guide Line 1800mm 

above the bottom right corner 

 

 

 

 Apply the Wall Favorite Exterior Walls 2  

 Start a new set of Walls from the intersection of the two Guide Lines and draw 

the Walls 9000mm by 5400mm 

 

 

 You can now remove the guide lines by right clicking them and ‘Erase Guide 

Lines’ and rub the eraser over the 2 lines. Hit Esc when done. 

 Change to 3D to see your results (F3 for 3D, F2 for 2D) 

 Use the Ctrl+click / Command+click to clean up the intersecting walls to end up 

with the following: 

 

 

 Save your file 
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Floor Slab 

Open the Slab Settings and set up a Slab as follows:  

 

 Use the Space+click (magic wand) to place a Slab based on the Wall perimeter. 

 Click on the bottom – outside edge of the walls once 

BIM Note: 

As with our walls, we can add information about the slab composition; 

thickness, what it is made of (Cut Fill) and what its finish is. 

 Highlight the Slab (Shift+Click) then using the Right-click pop up menu, choose 

Edit Selected Composite 

 In here we can see how this composite is put together 

 Building Material 

 Section pen weights 

 Skin thickness 

 

 

With floors that are not concrete slabs we can either model the sheet flooring and the 

individual timber members (joists, blocking etc) or we can create a ‘Composite’ that 

represents the floor that has the same total overall thickness. 

 

If you are not sure of the floor construction, we can place a simpler floor using the Basic 

Structre method, and just choose a Simple Building Material. 
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 Re-open the Slab Tool in the Tools box 

 Change the Structure Method to Basic 

 Now you can choose from your Preset Building Materials 

 And set your desired Floor thickness 

 

   

 

 Click Cancel 

Interior Walls 

 Open the Wall Settings and select the INT: Stud 90 Pb NZE Favorite 

 Set the Wall Geometry Method to Single Wall 

 

 Draw a Wall from the lower inside corner horizontally to the far left Wall 

 

Note: Wall Reference Lines need to touch to allow the wall intersection to automatically 

heal. Set the Wall Construction Method to the correct position to give the desired wall 

location. 

 

 

  

 

 

 

 Draw a Wall from the upper inside corner vertically to the bottom Wall 

 Drag a copy of the vertical interior Wall 1800mm to the left 

 Set the Snap Guides to Half and ensure it set to Between Intersection Points 

 

 Set the Wall Construction Method to Core Centre or (Wall Centre) 

 

 

 Draw a Wall halfway between the left Wall and the previously copied Wall 

 Your bach should look as follows: 
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 Clean up the Walls using the CTRL+click / Command+click to make it look as 

follows: 

 

 Save your file  

Roof (Single-Plane Roof i.e. Mono Pitch Roof) 

In order to create the roof accurately we need to see the Ground Floor Walls 

 Select 2. Roof Story from the Project Map 

 Use a Right mouse click over the top of 1. Ground Floor Story and select Show 

as Trace Reference 

 

BIM Note: 

When modelling a roof treat the roof thickness as either the Top Chord of the 

truss, or the depth of the Rafter. (In this project the roof has 140x45 rafters)  

The roof purlins, roofing material, soffit, fascia, gutter etc can be added later. 

 Open the Roof Settings and set up a Roof as follows: 

 First Choose Single-Plane Roof Geometry (i.e. Mono-pitched Roof) 
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 Draw the pitching/spring line along 

the inside face of lower Wall and click 

above the line to determine the slope 

direction 

 Use Space+Click to place roof on 

the outside face of the wall. 

 Select the Roof 

 Using the Pet Palette > offset all 

edges, select a corner node or edge and increase the Roof size by 450mm  

 

 

Hit the F3 key to view your model in 3D – we can connect the Walls to the Roof. 

 Making sure you are on the Wall Tool, Select All Walls (either Edit > Select All 

Walls or Ctrl+A/Command+A) 

 Open the Wall Settings and extend the Walls an extra 2000mm High 

 Use the Design > Connect > Trim Elements to Roof/Shell… command to trim 

the walls 

 Click on the Roof Plane   

 

 

 

 

 

  

 

 Then select the portion of the wall you wish to keep (PIN in place) 

 

BIM Note: 

Using the Connect command allows the Roof pitch to alter and the walls will 

automatically continue to connect with the roof. 
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Module 4 – Creating Viewpoints 
In Module 1 we learnt how to navigate a project. This module introduces you to the basic 
principles of creating additional views of the Virtual Building including: 

 

Elevations 

Sections 

 

BIM Note: 

This is where we see the first glimpse of the real power of the BIM.  When we 

create our Elevations & Sections, these are simply views of our existing 

Model. 

 

 

Elevations 

The template that we started this project with had 4 elevations already placed (as is the 

case with the New Zealand Template). This means that the elevations have been 

automatically created based on the settings of those Elevation Markers. 

 

These placed Markers are set up to produce presentation style elevations, with shading, 

vectorial hatching and colours based on the Materials chosen. 

 

Let’s examine the settings of the top (North) Elevation.  Select it and open its Selection 

Settings (Ctrl+T or Command+T) 

 

Alternatively you can Right Click on the North Elevation in the Project Map and choose 

Elevation Settings… 

 

 

 ID   - is the code for the elevation (this can be left blank, as we can 

get ArchiCAD to automatically number our views)  

 Name   - is the name of the view (North Elevation, South Elevation etc) 

 Marker Reference - tells the Marker where to look to get the information to fill in 

the Marker Information.   

 NOTE:   - Almost always this needs to be set to “The first placed 

drawing of the Viewpoint”  

 Status   - relates to whether the view automatically rebuilds itself based 

on any changes or whether you need to tell the elevation to update (Auto or 

Manual) 

 Horizontal Range - determines how ‘far’ the elevation ‘sees’ 

 Vertical Range  - can limit the elevation to a slice of the model; a floor level, or a 

set dimensional reange. 
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Marker and Marker Head set up how the Marker looks and what information is displayed 

within it. 

Most importantly here is that the Marker Text needs to be set to Referred Drawing. 

 

 

 

Within Model Display we set how the Elevation looks 

Uncut Elements are set to Own Material Colours (Shaded) 

The 4 options to fill uncut surfaces are: 

Nothing i.e. use no surface colours. 

 Uniform Pen Colour uses a single Pen for contour lines and no surface material. 

Own Material Colors (Non Shaded) uses the surface colors of the elements, this 

is best option for interior elevations to show ‘real’ colours. 

Own Materail Colors (Shaded) uses the element surface colour then adds 

ArchiCAD shading to make the flat surfaces appear 3D. 

Sun and Shadows is set to Custom, which means the ‘Sun’ will always come from the 

top right of the page.  (Note it can also be set to use the ‘real’ sun based on the longitude 

and latitude of the project and the time of day and day of year) 

And as always there is a Layer to place the Marker on.  
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 From the Project Map, double click on the Elevations to open them. 

 

 

Sections 

A Section is created in exactly the same way as an Elevation, however, instead of 

placing an elevation line ‘outside’ of the Building a section line ‘cuts’ through a part of the 

building. 

 Open the Section Settings and select the Section Model Pens NZE Favorite 

 Check that ‘with Marker Reference to:’ is set to The First placed drawing of 

the viewport.  

 

 

We’ll draw a section through the left most room, looking right 

 Start your section outside of the Bach above the western room 

 Moving the cursor down the page we can draw a vertical line through the room 

that finishes outside the Bach 

 It can be useful to turn on Grid Snaps to aid 

with accuracy of this. 

 

 

 With the Eye cursor click a little to the 

right (approx 2000m or 1 Grid) 

 The Eye is used to determine the 

direction of the Section or Elevation.  

 The Section will have appeared in the 

Project Map   

 Double click on it to view the Section 
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Distant Area Options 

ArchiCAD provides a large array of settings within the Section and Elevation Tools to 

provide you with full control over the style of a Section/Elevation. We’ll edit our recently 

created Section to show more information. To do this we’ll use the Vectorial 3D Hatching 

and the Distant Area Option in the Section/Elevation Settings. 

 Right Click in your Section viewpoint and choose Section Settings… 

 

 

 

 Within Model Display under UNCUT ELEMENTS activate Vectorial 3D 

Hatching. This turns on the hatching on any 3D surfaces – Walls, Roofs etc. 

 Click OK, to see the result – weatherbaords are now visible. 

 

 Right click and open Section Settings… again. 

 

 

 

 Tick MARKED DISTANCE AREA to turn this on. 

 Once you have activated the Marked Distance area, you can set how you want 

your Section/Elevation surfaces to look within this ‘area’, using the same settings 

as explained earlier; lets choose Uniform Pen and turn on Vectorial 3D 

Hatching. 

 Click OK. 

 

If placed correct you should see the weatherboards to the left of the building now appear 

as specific adding a sense of depth to the section. You can define the Section Marker as 

to where the Distance Area starts. 

 

 Go back to Plan (F2)  

 

Notice a new line to the right of the 

Section line, this is our Distance 

Area line – elements beyond this 

line will use our new settings. 

 

 Here you can change the 

position of the Marked 

Distant Area by clicking on 

the centre of this line and 

dragging it to any position 

you require.  
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Module 5 – Saving Views 
In this module you will create saved views for output.  You will learn the following principles: 

 

 View Filters 

 Layers & Layer Combinations 

 View Scale 

 Structure Display 

 Pen Sets 

 Model View Options 

 Dimension Options 

 Zoom Settings 

 

Creating Views – View Filters 

A View can be thought of as a completed drawing that is ready for output. A view uses a 

Viewpoint from the Project Map (e.g. Story, Section, 3D) and applies the following filters / 

settings: 

 Layer Combination  > What is the purpose of the View?  

 Scale    > Large or small scale (1:1 or 1:100?) 

 Structure Display  > Structural vs framed vs finish 

 Pen Set   > What is the weight and colour of the pen being used. 

 Model View Options > Changes the display of modeled elements.  

 Renovation Filter  > Not use in this course (Existing, Demolition, New) 

 Dimension Options  > Metric or Imperial 

 Zoom Setting   > Fit in Window (unless it’s a detail, then Current Zoom) 

 

The result is that multiple Views can be created from the same Viewpoint and can 

display different information at different scales. For example the Ground Floor Story is 

the Viewpoint that is used to create the Floor Plan, the Electrical Plan, and the Furniture 

Plan. The different plans are produced simply by turning on and off different Layers using 

Layer Combinations. 

Before making Views, we need to understand the various Filters. 

 

Layers & Layer Combinations 

As we have been placing elements (Walls, Slabs etc) to create our BIM model we have 

been placing these on specific Layers. Having elements on different layers allows us to 

have some items visible and other items hidden. This allows us to create different 

drawings with different information – for example a dimensioned floor plan and a furniture 

plan. 

 Open the Layer Settings dialog (Use either Document > Layers > Layer 

Settings (model views)… or Ctrl+L/Command+L) 

 You will see the dialog has all the Layers listed on the right. On the left is a series 

of Layer Combinations.  

 If you highlight a Layer Combination on the left you can see what layers are 

assigned to it on the Right 
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Layers 

Layers are divided it to four groups, In addition there is the ArchiCAD layer which is 

always visible. 

 

 Des:  (Design) These Layers are for modelled (3D) elements found in the 

Design Menu and the Design section of the Tool Box, eg Walls, floors, furniture, 

choose the layer that coincides with the elements purpose. 

 Doc:  (Document) These Layers are for elements under the Document menu 

and the Document section of the Tool Box eg dimensions, Fills, Text choose the 

Layer that coincides with the drawing being produced. 

 Import: “Manually” imported elements eg contour lines, site information from 

another file, or aerial photos. 

 Misc:  Design Images (scanned sketches), Hidden items (design options etc) 

Hotlinked Modules Master Layer, and Solid Element Operators. 

 

  Layer Combinations  

Layers Combinations are designed to produce particular outputs, be it a Plumbing Plan 

or a 3D visual. Each Layer Combination is named according to its purpose.  

 

 Highlight a Layer Combination eg Plan Plumbing on the left and note which 

layers are visible on the right, highlight another eg Plan Site and note the 

difference.  

 Each Layer Combination has a corresponding Doc: (Documentation) layer for 

the 2D annotation in the saved View. For instrance in the Plumbing Plan the 

layer Doc: Plumbing is visible this is the layer that all of the Dimensions, Text, 

Labels and any lines or fills that make up the annotation specific to the plumbing 

plan.  

 

  Scale 

This relates to the output scale of the drawing. I.e. 1:50 , 1:100 etc 

 

Note that text is not scale dependent by default, so changing scale from 1:50 to 1:100 

won’t change your text height, only the modelled elements change. 

We will cover text later. 

  Structure Display 

When using Composite Structures, for Walls, Slabs and Roof, we can set the Skins to be 

either: Core, Finish or Other 

 

 

 

Then we can assign what we actually want to see using the Structure Display Filter. 
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  Pen Set  

The Pen Set is what tells ArchiCAD what coulour to make its Lines.  We have create 4 

Pen Sets based on Scale of Output, and duplicated these with Printing Pen Sets. 

 

The Working Pen Set is full Colour, and the Printing Pen Set is mostly Black as we 

generally print in Black & White. 

 

 

 

 Go to Document > Pen Sets > Pens & Colors to open the Pen Sets 

 

The default Pen Sets are: 

 

Detailing NZE 19 - for detail work 1:1 to 1:10 

GA 1:100 NZE 19 - for G.A. drawings, Floor Plans, Sections etc at 1:100 

GA 1:50 NZE 19 - for G.A. drawings at 1:50 and maybe 1:25 Room Layouts and 

larger scale complete wall sections 

Site NZE - for G.A. Site Plan drawings at 1:200 – 1:500 

 

NOTE: Modelling Pens and Building Material Pens change pen weight with 

drawing scale, all other pens are fixed pen Weights. 

 

 

 

 

 The first 140 pens are for Modelled elements (although this is starting to 

change with the new Building Elements) and are set correct for the scale of the 

output.  These are organised in vertical columns based on elements or 

processes.  I.e. column 1 = General, column 2 = 2D Elements, column 3 = 

Openings (windows and doors), column 4 = Objects . . . columns for Slabs, 

Beams, Stairs, Roofs etc. 

 

 Then we have the 40 Building Material Pens in two horizontal rows. 141 – 180 

 

 We then have the New Zealand pens: 

 10 Drafting pens – colour describes pens weight no matter what scale you print 

from 0.001 to 3.0mm. 

 10 Grey Scale pens – different shades of grey that are grey even in the Printing 

Pensets. 

 A single red Revisions pen, for adding Revision Clouds and markups. 

 A single ‘Twink’ pen, designed to use when you want to remove a rouge line 

that you cannot by modelling. 

 14 colour pens – these are set to colour even in the Printing Pensets. 

 And 9 Renovation Pens, 3 for each – Existing, Demolition and New . 
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  Model View Options  

The Model View Options take over from where Layers stop.  A Layer is quite crude, it 

can only turn an entire element off or on.  But if the element is quite complex, like a door, 

a Layer is not sufficient. 

We may want to see the door hole only, or turn off the door leaf, or not see the door 

Number. 

These things are not on their own Layers so we need another way of controlling them.  

Enter MVO’s. 

 

 Go to Document > Set Model View > Model View Options  

 

We have 11 Model View Options, each with different settings (and different purposes): 

 

 01 Site       – for Site Plans or larger scale drawings (1:200, 1:500) 

 02 Drafting       – designed for detail line work 

 03 Building Plans Markers – for GA documentation with Door & Window 

markers ON 

 04 Building Plans No Markers – as above but with Markers off 

 05 Ceiling Plans   – For Reflected Ceiling Plans 

 06 Room Layouts – for mifd scale detail Layouts i.e. Kitchen, Bathroom etc 

 07 3D Exterior      – for external 3D views (handles & taps set to off) 

 08 3D Interior       – for Internal 3D views (handles & taps set to on) 

 09 Sections       – for Sections 

 10 Elevations       – for Elevations 

 11 Electrical       – for Electrical setout plans. 
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  Renovation Filter  

 

The Renovation Filter allows you to display elements based on their Renovation Status; 

Existing, Demolished or New. 

 

 Go to Document > Renovation > Renovation Filter Options… 

 

We have 9 Renovation Filters by Default. 

 

 00 NOT IN USE - New projects, all elements displayed no filters applied 

 01 Existing - all existing elements displayed including those to be demolished 

 02 Demolition Plan - displays Existing, and demolished elements with filter  

 03 After Demolition  - Shows only existing to remain 

 04 All Works   - Shows all works with New and Demolished  

 05 New Construction  - Shows Existing and New with filter applied  

 06 Proposed Plan  - New elements appear normal & Existing are white.  

 07 Finished   - New and remaining Existing elements displayed 

We are not using Renovation Filters in this project so we will use 00 NOT IN USE 

 

  Dimension Options  

This is maily for Metric vs Imperial, or Meters vs Millimeters.  We have set a NZE 

Dimension options which is all millimetres except for Area which is meters. 

 

 Go to Options> Project Preferences > Dimensions 
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Zoom Settings 

This is for setting what the extents of your view are, generally it is set to Fit in Window, 

which means the drawing keeps growing as the view changes, but for Details or cropped 

Plan views like Kitchens or Bathroom when can choose to crop the view. 

 

ArchiCAD NZE Template 

We have created an extensive document listing all of these features and how they 

are set up on the disc to give you a full understanding. You can access this under 

Help>ArchiCAD 19 NZE Template 

Creating Views - Organizer 

We can now use these filters to make some Views. 

 

Standard construction Floor Plan 

There are different ways of creating Views; we’ll start by using The Organizer 

  Open the Organizer Palette by clicking on the Project Chooser icon in the 

Navigator 

 The Organizer has a variety of modes. We need the View Editor Mode so make 

sure you click on the Project Map icon above the left part of the Organizer and 

click the View Map icon above the right part of the Organizer 

 The View Settings & Storing Options are set at the bottom left of this palette 

 To make a Construction Ground Floor Plan set the filters/settings as shown: 

 

 Now to actually create the View, pick up the Ground Floor Story Viewpoint from 

the Project Map on the left and drag it across the View Map on the right.  

Alternatively you can hit the Save View >>> button. 

 If you double click on the View you just created you will see a read out of the 

settings that the View uses and the actual View will be displayed in the current 

Window. 
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 Having selected the View you can also change the name,  

 Remove the View ID and 

 Change the name to Ground Floor Plan 

 

 

Presentation/Furniture Plan 

 The Plan Floor Layer combination is used for Construction Floor Plans.   

 If however we want to create a Sketch Plan style Floor Plan displaying loose 

furniture and hiding some of our construction information then save a view with 

the following modified settings.  

 Hit Save view >>> then rename the view Presentation Plan 

 

Ceiling or RCP Plan 

 Set the settings as below.   

 Hit Save view >>> then rename the view Reflected Ceiling Plan 

 

Section View 

Using the same process, select the Section, set the settings as per below and Save the 

View.  
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Elevation Views 

 If you need to create a series of Views that are essentially the same except for 

the Viewpoint (e.g. Elevations) you can create them in a single operation as 

follows: 

 Set up the Settings as follows: 

 

 

 Select all the Elevations on the left side of the Organizer – to do this use the 

Shift key to allow you to make a multiple selection 

 Now use the Save view >>> button (you could also have dragged and dropped 

as above.) 

 

 Having created your views you can now close the Organizer 

 

 

3D Views 

3D view can be saved as well, but for these we need to be in the 3D window. 

 Press F3 to bring up the 3D Window  

 Make sure you are in a Perspective View 

 

 

 

 Orbit (middle mouse button and shift key) to a North Western point looking at 

the Bach 

 Switch the Navigator to the View Map  

 

 

 

 Click the Save Current View… button at the bottom of the Navigator 
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 Make sure the Source View says Generic Perspective 

 Set the Layer Combination to 3D: Model All 

 Set the Scale to 1:50 

 Set the Structure Display to: Entire Model 

 Set the Pen Set to GA 1:50 NZE 19 

 Set Model View Options to 07 3D Exterior 

 Set the Renovation Filter to 00 NOT IN USE (as we are not using it) 

 Set to generate the 3D view generate in the 3D Window  

 Click Create 

 Highlight the new view in the View Map, should be called Generic Perspectice, 

and rename it to NW Perspective 

 Orbit to a North Eastern point and create another View named NE Perspective 

Layouts 

Having created a series of Views the next step is to place the Views onto a page or 

Layout ready for output. 

We’ll cover Layouts and Drawings in more detail later but we’ll have a brief look now. 

To create Layouts we again use the Organizer this time however, it must be set up in 

Layout Editor Mode. 

 

 Open the Organizer and switch the left side to View Map and the right side to 

Layout Book, the title of the Organizer should read Organizer – Layout Editor 
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 On the left hand side select all the Views you have created, remember to use the 

Shift key to select multiple items 

 Click the Place Drawing >>> button  

 

 ArchiCAD will now create a Layout for each View and then proceed to place 

each View on a Layout.  

 This process will take a few seconds and a progress bar is displayed to show 

progress 

 Once finished, close the Organizer and change the Navigator to Layout Book 

 

 

 

 Double click the different Layouts and see the Views of the different parts of the 

Bach 

 

You can return to the Layouts at any stage and ArchiCAD will keep them up to date. 
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Module 6 – Doors and Windows 
This module introduces you to a key component of any Building – Doors and Windows. 

For this exercise we’ll start to explore the Cadimage Doors + Windows. 

Bach Doors and Windows 

From an ArchiCAD perspective when using standard Aluminium Joinery it is hard 

determine if an opening should be classified as a Door or a Window. 

 

For all the Exterior Joinery we’ll use the Cadimage Window. 

 

Please note that all Doors and Windows must be placed into Walls. 

 

BIM Note: 

Windows & Doors are not just the physical opening size, information needs to 

be added about opening style, frame type and dimensions, additional trims, 

reveals, architraves, exterior finishes and material colours. 

Windows/Exterior Joinery 

We’ll start by opening the Window Settings dialog. 

 Double click on the Window Tool in the Toolbox 

 Navigate through the Linked Libraries to find Cadimage Library 19  

 Click to highlight the Cadimage Window icon 

 Now we are ready to create our Windows (and Exterior Doors)  

 

The initial dialog has three selections: 

 

 Sketch a Window 

Use this in the early design phase of your project to place quick windows with 

basic mullion configurations 

 Choose an Existing Window 

Use this method is you have already imported your Cadimage Presets Windows 

into your project 

 Parametrically Design a new Window 

This is the full blown design everything metthod 

 

We will start with the Sketch a Window Method. 

 Select Sketch a Window 
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We simply want to create an opening to represent the window below 

 

 Firstly we set the size of the window (frame) 

 

BIM Note: 

We can use Rough Openings in ArchiCAD but the frame size is always the 

actual frame size, the Rough Opening can be set by using ‘Shims’ from within 

Frame > Extensions > Shim Spaces. The when we dimension the opening it will 

dimension the Rough Opening. 

 

 Within Preview and Positioning set the width 2400, height 450 and head height 

2200. (Header to Story 1) also set the Preview to Elevation. 

 

 

 

Within Sketch Design Settings 

 Set the Horizontal Grid to 1 
 And the vertical Grid to 2  
 Hit the Re-set Grid button 
 Then OK 

 

 

 

To place the window, ensure the Window placement method is set to Centre 

Method 

 

 Set the Special Snaps to Half and ensure it set to Between Intersection Points 
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Rest your cursor over the outside edge of lower South Wall (Bedroom 1) 

 Click the Mid-point marker 

 When placing a Window the first click indicates the Outside (SUN), the second 

click is whether the window is mirrored, clicking to the outside and to the left of 

the centre line (looking from the outside) will place a window as it appears in the 

Window Preview, clicking to the right of the centre line will mirror the Window. 

 

Preview your result in Elevation – Choose South Elevation 

 

 

This is fine to indicate the Design intent of a framed opening in the wall.   

For Developed Design, and Construction Documentation, we can to do better. Select the 

placed Window and open its Settings (Ctrl+T PC or Command+T for Mac) 

 Check the Detailed Design button 

NOTE: The Developed Design Button also allows you the further edit the Sketch, and 

simply has fewer options than Detailed Design. 

 

 

 

We want to further refine this opening by making the smaller sash appear as an awning 

window.  As below 
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 Within the Setout tab, select Glazing 

 

 

 Select the right window panel, and change its Panel Width to 600 

  Then change its Panel Type to Awning 

 Click OK, and your window will update. 

 

 

Notice the window now shows its 600mm opening sash. 

Flip back to Plan view (F2), and place another window in the hallway, but this time 

mirrored. 

 Pick up the properties of your first placed window (Use Alt+Click for PC or 

Option+Click for Mac). 

 Find the center mark of you hallway, and click to place the window. 

 With you final click, click to the right of the Centre line looking at the building 

from the outside. 

  

 

 

Notice the opening sash is on the left this time (i.e. it is mirrored) 

 

 

Continue to place a window in the Living room – not mirrored, another in the East wall 

mirrored and one in the West wall – not mirrored 
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Next we’ll add Windows in the North Wall:  

 

 

 

 

 

 

 

 

 

 Set the width 1800, height 1350 and head height 2200.  

 

 

Next we want to keep the same opening sash width, but we want to add additional 

opening sashes.  

 Use the Setout > Glazing highlight the right Right Panel 

 Then where it says Panel Type change this to Grid: 

 Use Divide Panel to split the sash into 3 panels 
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 Before placing window change the placement method to Side 1 

This allows the Window to be placed from its ‘Right Side’.  We want to place this window 

800mm in from the exterior corner of the building.  

 Rest your cursor over the exterior corner – this will activate the Snap Guide 

 Move your mouse to the left and type 800 -, then Enter  

 When you hit Enter the right side of the window is positioned 

 The cursor changes to the door swing icon (orientation) – click to the left of the 

centre line as if you are looking at the window from the outside. 

 

 

 

 Repeat this exercise for the Window on the left hand side of the same wall, but 

this time place the window mirrored. 

 

In between the two windows just placed you need to create a set of bi-folds 

 

 

 Open the Window Settings  

 Set the width 2400, height 2200 and head height 2200 

 Use the Setout > Glazing interface to: 

 Delete the Right Panel by selecting it and hitting the ‘-‘ button 
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 Select the remaining Panel and change it to a Right Hung Door with 2 leaves on 

both sides 

 

 Change to Extras & tick ‘Opening Direction’ set the doors to open to the Exterior 

 

 Go to to Setout > Doors and set the Door Type to Bi-fold  

 

 

 Set the Door Style by going to Door Leaf > Leaf and choose your style 

 

 

 Set the Panel to Insert to Glass 

 

 

 

 Click OK 



INTRODUCTION TO BIM   

Introduction to BIM   Page 45 of 166 

 Change the placement method back to the Centre and place the Window in the 

centre of the Wall – Remember to click to the left of the CL looking at the window 

from the outside. 

 

 

 

The bathroom window is next: 

 

 

 

 

 

 

 

 

 

 

 

As this window is very similar to our Kitchen/ Living Windows we can use this as a start 

point. 

 Pick up the Properties of your placed window with the Eyedropper (Alternatively 

use Alt+Click for PC, Option+Click for Mac) 

 

 

 Alt+Click or Option+Click on the Kitchen window 

 Open the Window Tool 

 Within Preview and Positioning set the width 1200, height 1350 and head 

height 2200. 

 

 

 

 Within the Setout > Glazing interface select ALL Panels 
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 Set the Panel Width to 0 (this means the panels are equal) 

 Click OK and place the Window in the centre of the bathroom wall. Not mirrored 

(click to the left of the centre line looking at the window from the outside) 

 

Now for the Bedroom sliding doors.   

NOTE:  We are still using the Cadimage Window Tool for this ‘Door’ 

 

 

 First set the Width to 2400 and Height to 2200 within Preview and Positioning 

 

 Within the Setout > Glazing tab select the left panel and set it to Right Hung 

Door 
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  Set the door panel to open to the Interior 

 Click the Panel Type button, change it to Extras  

 Set the the opening direction to Interior 

 

 

 Select the Doors tab 

 Set the Door Type to Surface Slide 

  

 

 Select the Door Leaf tab, then Leaf 

 

 

 Choose your Leaf Style and set the Panel to Insert to Glass 

 

 Go back to the Glazing tab and highlight the right Panel (by clicking on it) 

 Set the Panel Type to Awning 

 Change Panel Type to ‘Grid’ 

 Divide the Panel into 5 Horizontals 
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 Click OK, and place the Door via its centre point, in the centre of the Bedroom 2. 

 Place the door mirrored – make you final click to place the door on the right of 

the Centre line looking at the window from the outside. 

 

 

 

 Place an identical Door, but this time not mirrored in Bedroom 1 –make you final 

click to place the door on the left of the Centre line looking at the window from 

the outside. 

 

 

 

 

 

NOTE: Using the Divide into equal divisions means that the panels are identical, if you 

wanted 5 horizontal panels but the bottom 2 were fixed, you need to create 2 separate 

panels with the top one set to Awning and split into 3 and the bottom one set to fixed and 

split into 2. 

 

To do this you choose the ‘Edit the Setout…’ button to add a panel above: 

 

You can control the sizes of the lower and upper panels under Setout>Dimensions 
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The final item you’ll place is the Front Door; however, you’ll still use Cadimage 

Windows. 

While not entirely the same we’ll ‘pick up’ the attributes of the just placed Bedroom 1 

Sliding Door and modify it as required. 

 

 Alt / Option+Click on the edge of the main Window in Bedroom 1 – before 

clicking make sure the Window element is highlighted 

 Open the Window Settings (Ctrl+T or Command +T) 

 Set the Window (Door) size as 1400 w x 2200 h with head height 2200mm within 

the Preview and Positioning 

 

 

 Use the Setout > Glazing interface to: 

 Change the Left Panel from a Right Hung Door to a Left Hung Door with a 

Panel Width of 810mm (this is the Leaf size) 

 

 

 Under Doors change the door type to a Single Swing  
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Use the Door Leaf interface to select a flat panel door, set the door style to 0-B 

   

 

Choose Flat for the Panel to Insert.  

   

 

 Click OK 

 

 

 

 

 

 Use the Centre placement method and place the Window midway between the 

exterior Wall and the Corridor Wall 

 Click to have the door as it appears in the Preview Window (i.e. not mirrored) 

 

 

 Having placed the windows check out the 3D Views and the Elevation 
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Interior Doors 

 The interior doors are created using Cadimage Door. 

 Open the Door Settings and make sure you have the Cadimage Door Door 

selected. You will see the following interface:  

You have similar initial option to the Cadimage Window Tool: 

  Sketch a Door – use this method to create a quick sketch design door 

  Choose an Existing Door – use this method if you have premade Doors 

Parametrically Design a New Door – use this method to create any door from 

scratch. 

 

We will just use a simple door for our Bach. 

 

 Select the Sketch a Door option  

 Just change the left leaf width to 710 and click OK: 

 

 

 

 Click OK 

As with Windows two clicks are required to place a Door: 

 The first indicates the insertion point, Center, Side 1 or Side 2 

 The Second click indicates in which direction the door swings (for a typical door 4 

different swings are possible, make sure you click well towards the area you want 

the door to open to)  
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 Ensure the Door Placement method is set to the Edge (Side 1) 

 

 

 The doors are all placed 50mm from the nearest wall intersection (allowing for a 

50mm stud). 

 Hover your cursor at the wall intersection until the Snap Guide appears 

 Move your mouse to the left and type 50 then Enter 

        

 Choose the door swing orientation with the second click. 

     

 

Now place an 810 door into Bedroom 2 

 

 Select the Door Tool in the Toolbox and change the width to 810 

 With the same ‘Side 1’ placement, place the door 50mm from the wall junction. 

 

  Place the final door into Bedroom 1 

 

 Place this door via its centre point, and choose the mid point of the end Hallway 

wall. 

 Make the door swing to the outside wall. 
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Empty Opening 

Both the Door and Window tool allow you to place empty openings. These are simply 

holes in the walls with no Door or Window geometry. 

 

 Open the Door Settings and click the Empty Opening button 

 

 

 Set the size of the opening to 1000 w x 2000 h and ensure the Sill height is still 0 

(Sill to Story 1) 

 Click OK 

 Place the empty centered in the right Hallway wall 

 

ArchiCAD still thinks this Empty Opening is a Door and as such gives it a Door Number. 

 

 

 

 To remove this, select the Empty Opening and in it’s settings navigate to 

Dimension Marker and set the door to use No Marker.  
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Module 7 Extras – Bach 
Extensions 
This module involves some additions to the bach. The additions include a deck, pergola and 
a carport. You’ll also add some furniture to the plan. 

Deck 

To create the deck we will use the slab tool. The deck runs along the full width of the 

north side of the Bach. 

 We’ll create a quick Composite to mimic our Floor structure: 

 140 joist + 40mm decking members 

 Open the Composite settings – Options > Element Attributes > Composites 

 Choose an existing Composite that is similar to the one we want to make - Floor: 

Joists 140+20mm Ply is close. 

 Select Duplicate and give our new composite a descriptive name – Floor: 

Joists+40mm decking 

 Click OK 

 Select the Slab Tool 

 Choose our new Composite 

 

 

 

 Set the Slab to start 100mm down from the Ground Floor (-100) 

 Make sure the Slab Geometry method is set to Polygon 

 

 

 

 Click the top right corner of the Bach and draw the first edge 1800mm to the 

north 

 Proceed to the left until you are in line with the left hand side of the Bach (you 

can ‘pull’ a Guide Line off the left corner to ensure you are accurate) 

 The remaining points of the deck are the edges of the bach; you should end up 

with the following 

Note:  If you make an error whilst creating your polygon shape; pressing 

Backspace will remove the last point. 
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Carport 

On the south side we are going to add a Slab and extend the Roof to create a carport.  

 Open the Slab Tool – because this slab is not a composite structure, i.e. it’s just 

a simply non-insulated concrete slab, so we don’t need to choose a composite. 

 Choose Basic Slab type and set the Building Material to Concrete 

 Change the slab level to -100mm 

 

   

 

 Set the Slab Geometry method to Rectangular 

 

 

 Create a Slab 5400 x 3000mm from the lower right corner 

 

 

 Click on the lower right corner to start the slab, move your mouse in the general 

direction of the lower left corner of the finished slab.  Using the Tracker, Type 

5400, then Tab, then 3000 then Enter 

 

Roof Editing 

 Select the Roof Tool 

 Select the Roof 

 Use the Pet Palette to add a node to the south edge 

 This node needs to be 450mm to the left of the new Slab edge (450mm is the 

roof overhang) Select the edge of the roof, highlight the intersection point 

between the roof and slab, move node to the left and type 450 into the Tracker, 

then Enter 

 

 

 Extend the Roof edge using the Pet Palette 

 The edge should be extended 3000mm to the south  

 

 

Columns 

 You can use columns to form the side of the carport 

Open the Column Settings and set up a column as follows: 
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 Column Top – Not Linked 

 3000mm tall 

 Timber – Wall Building Material 

 Bottom left placement point 

 Override surface material to Wd-Pine Vertical 

 Layer = Des: Walls 

 Place the Column at the bottom left corner of the Slab 

 

 

 

 Select the Column and use the Multiply command (right click menu Move > 

Multiply…) to create 3 copies that are equally spaced along the edge 

 

 Make sure you pick up the bottom right corner of the Column when you multiply it 

so that you can snap this point to the bottom right corner of the Slab 
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 Switch to 3D (F3) 

 Select the columns. (Have the Column Tool selected and hit Ctrl+A or 

Command+A to select ALL Columns) 

 

NOTE: The InfoBox will tell you how 

many columns you have selected. 

We should have 4. 

 

 To use a different method this time also select the Roof you will be trimming to 

and with all 5 elements selected (4 columns & 1 roof). 

 Right Click, Choose Connect > Trim Elements to Roof/Shell. 

 

 Choose ‘Use Roofs’ and click Trim: 

 

Furniture & Fittings 

To help identify the function of the various rooms you can add some furniture and fittings. 

Furniture and Fittings are Objects. ArchiCAD has an extensive Library of Parametric 

objects that ship with ArchiCAD, in addition to this is the BIM Components Portal; a 

global resource of objects that can dropped into your project as easily as the ones in the 

standard ArchiCAD Library. 

When placing initial design or space holder objects – the ‘Layout’ objects are great. 

Beds 

 Open the View from the View Map Presentation Plan (remember this is the Plan 

that will display loose furnishings)  

 Open the Object Settings dialog and Type ‘bed’ into the Search field at the top 

left. Select Bed Layout 19 

 Make sure the following settings are correct: Height set to 0 to floor & on the 

Ground Floor and correct Layer Des: Furniture 

 In the preview window set the Anchor Point in the edge of the bed 
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 Choose to place the object with the Rotated Geometry Method 

 

 Place the first bed 1200mm from the wall 

 Highlight your mouse on the upper left corner until you get a Snap Guide 

 Move down and Type 1200 Enter, and you will see a preview of the Object 

 Rotate the object so it is aligned with the end wall. 

 Place the second bed 800mm from the wall 

 

 

 

Re-open the Object Tool, and see the other Layout Objects – Table Layouts, Sofa 

Layouts etc 

These Layout Objects typically contain a number of objects – Bed, bedside tables & 

lamps, dining table plus chairs etc.  One of these grouping objects is the Kitchen Layout.  

 

 

Kitchen 

 Select the Kitchen Layout 19 object  

 For our design we need to Mirror the object and Rotate 270º 

 Set the Layer to Des: Fittings General. This is the default layer for major fittings 

that are seen on all plans such as Kitchens and Stairs.  
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 Place the Kitchen Layout object in the top left corner of 

the living area  

 The Kitchen Layout object contains Benches, Wall 

Cabinets, Tall Cabinets and of of the typical 

appliances you would expect in a Kitchen. 

 Select the Layout Object and you will see each 

individual element has a Pink Dynamic Hotspot. 

 The Dynamic Hotspots allow the stretching and 

arrangement of the elements they will automaticaly snap 

and jump from each set of benches. 

 Arrange your Kitchen similar to the one below. 

 

 

NOTE: This can be done in 2D or 3D, for 3D we can place a 

Marquee to limit or 3D View extents 

 Select the Marquee Tool, draw a ‘box’ around our 

Kitchen. 

 

 

 Hit F5 for PC or F4 for 

Mac to view in 3D 

 

  

 

 

 

 

 

 

 

 

 

Bathroom 

Because of the variant nature of bathrooms, there are no layout objects for these, so we 

need to use individual objects. 

 Set the Layer to Des: Fittings Plumbing 

 Search the library for various bathroom fittings and add a Bath, Basin Cabinet 

and WC to the bathroom 

 Bathtub 19 

 Basin Cabinet 

 WC LT 19 

 

 

 

 

 

 

 

 

 

There are many more objects within the libraries 
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Pergola 

The client wants to create a pergola over the north deck.  

We can use the Beam tool and Column Tool to create this. 

  Open the Beam Tool and set the size for the Pergola Purlins like so: 

Note: Setting the End of the Timbers to a different material will mean the fills don’t 

blend.  ArchiCAD treats two like fills that are adjacent to one another as one fill.  This 

is especially handy when using fills on walls that automatically clean up 

 

When placing beams, they are setout by 

their centre line, once the first beam is 

placed move it half its width (22.5mm) so 

that it is flush with the face of the wall. Or 

use ‘With Reference to’ and type X 22.5 + 

from the wall corner or you can change 

the Reference Line position in the settings 

 

 

 Offset the purlins 900mm using the 

Multiply Tool from the Pet Palette 

 The last one will fall off the end, Select it and Move it back 45mm. 
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 The Rafter Beams will extend into the Living wing of our Building. 

 Draw a Marquee around the ends of these Beams, Select the Beam Tool and 

use Ctrl/CMD A (Select All) to select all the Beams inside the Marquee. 

 

 

 

 Trim the Beams using the Split Tool and split along the outside face of the wall. 

(keep the bottom half of the beams selected, so you can delete them). 

 

 Deselect the beams & reopen the Beam Tool Settings for the support Beams 

 

 

 And draw the Support Beam the length of the front edge of the Deck. 

 

 

 Now open the Column tool and the settings should be as we set them for the 

Carport. The only change we need to make should be the Anchor point to place 

the Column at the top left. 
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 Use Multiply and place 7 evenly spaced posts. The number of copies you need 

is 6 which equates to the existing one plus the new 6  

 

 

 When selecting the post to multiply use the top right corner so you can accurately 

locate the corner of the pergola 

 

 

 

 To finish at the top right corner of the Deck. Zoom in to ensure you get it exact. 

 Go to the North Elevation, notice the columns are too long. 

 Select all the Columns, have the Column Tool selected and hit Ctrl+A or 

Command+A 

 Select the Adjust Tool from the Top Toolbar. 

 

 

 

  Adjust them, using the Adjust Tool by clicking the underside of the Pergola beam 

 

 See the result in 3D 

 

 Save your file 
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Module 8 – Site and Foundations 
This module introduces you to Site and the buildings connection with the site. We will use 
the Cadimage Sites Tool and the Mesh tool to model & document our site and use a 
Complex Profile to model the Footing and Slab Thickening. 

 

 There are two distinct ways to create your Mesh: 

1. From a DWG or similar supplied via a Surveyor.  With this DWG you can trace 
around the Boundaries to form you Mesh, then use the Cadimage Tools to 
automatically create your Boundary objects. 

2. From a C.T. (Certificate of Title) obtained from Council that have the Boundary 
angles and lengths.  Using the Cadimage Boundary Object we can add the 
Boundarys then Create the Mesh from these Objects. 

 

For the purposes of this Training course we will use Method 2.  
For instructions on Method 1 please see the Appendix of this Training Course. 

Site Boundary & North Point 

We model our Site information on the Sea Level/Datum Storey so we can provide 

accurate Levels and Dimensions releative to this in our project. 

Before creating any Boundary information, we need to add a North Pointer to our Project. 

 Navigate to the Sea Level/Datum Storey.  

 Use the Quick Options Pallette to set the Layer Combination to All and the 

scale to 1:200 

Now we can place our North Arrow 

 Choose Cadimage > Sites+Massing > Place North Arrow 

 Choose a style you prefer and adjust the size of the symbol to 2500 

 In the Floor Plan and Section settings set show on Stories to All Stories 

 Set the Layer to Doc: Site 

 

 

 Place the North Arrow in 

the Top Right of the 

building.  
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Next we will create the Boundary lines of our site. To input Boundary Lines we need to 

be able to input angles as degress minutes and seconds instead of Degrees. 

 Go to Options > Project Preferences > Working Units… These are the units of 

input as opposed to Dimensions which is the display of units. 

 Set the Model Units to meter and 2 decimal places 

 Set the Angle Unit: to degrees, minutes, seconds and click OK. 

 

 

Now we will start creating our boundary lines.  

 We are replicating the typical workflow of if we had received a Certificate of Title 

as our Site Information. 

  Cadimage > Sites > Survey Boundary (Objects) 

 In the Cadimage Boundary Settings you can set up the HRB (Height in relation 

to Boundary Envelope) values for your Town Planning information. We will stick 

with the default which is Auckland Residental:  

 

 North = 2m @ 55° 

 West = 2m @45° 

 South = 2m @ 35° 

 East = 2m @ 45° 

 

 

 Set the Layer to Des: Site Boundaries 
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NOTE: When adding data from a C.T., we will generally be more accurate than the 

Surveyor’s dimensions & angles (in that they work in rounded Meters and we work in 

Milimeters i.e. 27.80M could be 27797mm), so it would be wise to choose a corner of the 

site that is NOT important, i.e. that is not a front yard or where we could be infringing on 

the HRB. 

 

 Our start point is the Project Origin down the bottom left of our project. Click 

here. 

 

 

 Now you will be asked for the Bearing and Length of the Boundary Lines. 

 The first Boundary is    1° 28' 49"    27.93m 

 Add a space between the Degrees and Minutes and Seconds i.e.   1 <space> 28 

<space> 49 

 Tab to the Length field and type 27.93 and click Add 

 

 

 

 Working in a Clockwise direction around the site. 

 The second Boundary is  83° 1' 6"    26.45m 

 The third Boundary is   4° 8' 3"     35.57m 

NOTE how this boundary has placed 180 degress from our intended direction; click Flip 

to flip the Boundary 180° 

 

 

 

 The fourth Boundary is   100° 5' 4"    24.78m 

 This will need to be Flipped also 

 We rarely find that the bearings and lengths form a perfect closed shape so even 

though it looks as if it has closed; we have to hit the Finish button to add the last 

tiny boundary and close the shape. 

 Hit Finish 
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If we zoom in on the last Bounday element placed we can see that is it 0.01m in length. 

This Object needs to be here so that the Boundaries closes, but we do not need to see 

the information.  We can simply Open the Object settings and turn this info off.  

 

 

 

 Select the Boundary Object (Use Shift & Tab to select the correct boundary) 

 Open its Settings (Ctrl+T or Command+T) 

 Untick Show Text? under the Symbol settings. 

 

 

 

Site Mesh 

 Now we need to add our Site Mesh. Our Site is located in a lake side 

development so even though we are close to lake level we are far above sea 

level which is our survey Datum. 

 We have been provided only with a spot level at each corner of the Site. 

NOTE: For detailed steps on adding Contour information, refer the the Site Countours 

instruction sheet in the Appendix at the back of this Training Guide. 
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 Open the Mesh Tool from the ToolBox 

 Set the Relative Base Level to 144 M (make this a nice round number below 

your lowest site level, our lowest level is 144,170 - remember we are still set to 

use Metres as our Working Units) 

 

 NOTE: The main reason we do this is we are trying to avoid having a very tall 

telescoping Site that is 140 M high, we just want a ‘Plinth’ of dirt under our building. 

 

 

 

 Set Floor Plan Display>Outlines>Ridge Selection to Show User defined 

Ridges Only, this removes the triangulation in Plan View 

 In Model choose All Ridges Smooth, this removes the triangulation in 3D view 

 Layer to Des: Site Mesh Proposed (we are using proposed in this training 

course – but in Practice the first mesh should be Existing, and the modified mesh 

should be Proposed) 

 Click OK 
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 Select the 5 Cadimage Boundary Objects (4 main ones and the tiny one) 

 

 

 Cadimage > Sites > Create Mesh from Boundary to automatically create the 

Site Mesh based on your boundaries.  

 Have a look in 3D, zoom to Extents to see a thin mesh floating 140 metres above 

your building. 

 Now we need set the R.L. of the Mesh. Flip back to 2D and Select the Mesh  

 In the Info Bar Change the Layer to Des: Site Mesh Proposed 

 Click on the top right corner node of the Mesh. 

 

 

 

 From the Pet Palette choose Elevate Mesh Point 

 From the new dialog set the Reference level to Project Zero 

 Set the Height to 144.170 

 Click OK 

 Elevate the other three corners to their respective elevations. 

 

NOTE: You will need to zoom in very close to pick up the two boundary points that 

occupy the bottom left corner of our site. 

 

Our building now needs to be repositioned onto our Site. We can do this by defining our 

proposed floor level for our Ground Floor Story. 

 Open Design > Story Settings 

 Storey Levels are defined relative to each other. Our Datum is 0.Sea level 

and our Proposed Ground Floor Level is 145.100 Enter this in the Height to Next 

field for the Sea Level / Datum Story and you will see the Story’s above 

automatically recalculate their Elevations. 

 

 

 Hit OK 

Your saved views will automatically update and the Building will be sitting on Site Mesh.  
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Building Envelope (HRB) 

We can now place a Building Envelope over our site that reflects out HRB controls.  This 

will allow us to better position our building so it conforms to Council requirements. 

 Navigate back to our 0.Sea Level/Datum Story 

 Select the Mesh 

 

NOTE: The Boundry elements need to be visible before the HRB will be able to 

be created.  If they are not showing, open the Layers (Ctrl+L or Command+L) 

and turn on the boundary element layer.  Des: Site Boundaries. 

 

 

 Go to Cadimage > Sites > Place Building Envelope. 

 Set the Rolling Height to 8000mm (i.e 8.0 M) 

 Flip to 3D and see your envelope as a glass box.  

This is great but can be difficult to see, so we can change the glass material to solid 

paint. 

 Select the Envelope and open its Settings (Ctrl+T or Command+T) 

 Within Model, Override the Surfaces to Paint-Vermilion 

 

We can also get the Yard setbacks to show in 3D. 

 Navigate back to our Sea Level/Datum Storey. 

 Select the 5 Boundary Objects and open their Settings 

NOTE: The easiest way to do this is to place a Marquee around the Site,  

 Select the Object Tool in the Toolbox  

 Select all Objects with Ctrl+A or Command+A ,  

 Then just remove the North Point Object by Shift-clicking on it.   

 You know you have done it right if in the top right of the Info Box is says  

Selected: 5 

 

 

 

 Open their Settings with Ctrl+T or Command+T 

 Within the Envelope tab, tick the box next to the Apply Yard Cut in 3D image 
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If the Yard Setbacks are not the same all round the site we can set them manually. 

 Select the Northern Boundary (assuming this is our Road Bounda ry) Click 

on the Pink Editable Hotspot 

 From the Pet Palette choose Move Node 

 And set the distance to 5 M 

 

 

 Flip back to 3D and see your Builing envelope is displaying the Yard setbacks.   

 

Also NOTE that we are illegially within these yard setbacks. 

 

 

We can now use this Building Envelope to position our building. 

NOTE: We are actually moving the Site in relation to the Building as opposed to moving 

the Building on the Site. 

 

 Navigate back to our Sea Level/Datum Story 

 Select ALL the Site bits & pieces; Meshes (x2), Boundary Objects and North Pt. 

NOTE: The easiest way to do this is to use a Find & Select.  We have saved 

some Criteria Sets to make this process easier. 

 Open Find & Select using Ctrl+F or Command+F 

 From the pull down select the Cadimage Boundary + North set. 

 Then hit the big ‘+’ key 
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6 elements should be selected at the top left – if not you may not have your North 

point Layer ON. A quick option is to hit the ALL Layer Combination in the Quick 

Options palette. 

 

 

 Then select the Mesh Tool, and hit Ctrl+A or Command+A to select All the 

Meshes 

 Now Drag and/or Rotate these so that the Site is accurately positioned. 

NOTE: You may wish to turn ON the Ground floor Plan so that you can see your Deck. 

 Change to your View Map 

 Right Click on Ground Floor Plan 

 Choose Show as Trace Reference 

 

Create a Site Plan 

We can now create a View of our Site Plan 

 

NOTE: Site Plans can be created from either the Sea Level Story or the Ground 

Floor Story, depending on what you want to show. 

We want to show the ground floor walls in relation to our site, so we will use the 

ground floor as our site plan source. Another option would be you just want to see 

your roof outline, in this case you would use Sea Level as your source. 

 

Navigate to the View Map > Ground Floor Plan and Save a new View with the 

following settings as our Site Plan 
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Foundations 

To model our Foundations we are going to use a Beam. Beams, Walls and Columns can 

be shaped in any form using Complex Profiles. In this instance we will use a Beam 

shapped like a Slab Edge Thickening. 

 

As we have finished with our Site modelling, we should change our Working Units back 

to milliemters and our Degrees back to decimal. 

 

 Options > Project Preferences > Working Units These are the units for input 

of measurement as opposed to Dimensions which is the display of units. 

 Set the Model Units back to milimeter and 0 decimal places 

 Set the Angle Unit: to decimal degrees and click OK. 

 

 

 

 Select the Beam Tool from the Tool Box and open the settings  

 Choose Complex Profile Structure type 

 From the pullout select Slab Edge Thickening 

 Make sure the Home Story is 1. Ground Floor 

We are going to apply this Foundation to the Carport Slab. Bearing in mind that our 

Carport Slab is 100mm lower than our Floor level and is 100mm thick we need to set our 

Foundations 200mm down. 

 Set the Relative Height to -200  

 Set the Layer to Des: Floor Foundations 

 Set the Beam to draw a Chained sequence of Beams.  

 Snap to the corners of the Carport Slab in an anti-clockwise direction. 
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Now we’ll add foundations to our main slab 

 

 From the Complex Profile pullout, choose Slab Foundation Footing 

 Set the Relative Height to -100 

 Snap to the Corners of the main floor Slab, again in an anti-clockwise 

direction. 

 Check your Section and 3D. 

Steps 

To provide some connection between the Deck and the Ground plane we will model 

some steps.  

 Eyedrop on the Deck   

 Draw a rectange 9000 x 280, from the top right corner 

 

  Then drag a copy of this to form 2 Steps. – Select the new Step, Hit Ctrl+D then 

Ctrl (for PC) or Command+D then Alt for Mac 

 View the result in 3D, note you will need to lower the steps use the Move option 

from the Pet Pallette 

 

  

 

 

 

 

 

 

 

 

Adjust 3D Views 

Our saved 3D Views are now elevated incorrectly – as we have made changes to our 

Storey levels. 

 Double click to open one of your saved NE/NW Perspective views. 

 

 You will notice that your 3D views are looking at the underside of the site 

navigate to a position where you can see the building again. 

 

 Right Click on the View you need to update and choose Modify setting with 

current window settings. 
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Module 9 – Annotation 
This module takes you through some of the 2D related elements that you need to use to 
produce contract documentation. 

Elements include: 

Dimensions 

Fills & Cover Fills 

Text & Labels 

You’ll also learn how to control the display of particular elements via the Model View 
Options. 

Dimensions Important Concepts 

There are 4 individual Dimension Tools that create the various dimension types.  

 Dimension Tool  •   Level Dimension Tool 

 Radial Dimension Tool  •   Angle Dimension Tool   

We’ll use another file to examine the various Dimension Tools and their settings. 

 Open the Dimensioning.PLN file. 

 With the Navigator set to show the View Map, double click on Finished 

Exercise (this is our finished Dimension view) 

 

 Double click on DIM Exercise 

 Select the Dimension Tool from the Toolbox  

Horizontal Dimensions  

 With Dimensions it is critical to ensure you dimension consistantly, ie in a 

standard floor plan it is the Wall positions that are dimensioned. So we need to 

be consistant in only dimensionsing wall points. 

 Click to place horizontal dimensions along the top of the project. 

 To ensure you dimension the correct wall points use Tab to cycle through the 

elements where there are Multiple Elements. 

 

 

 

 Double Click to finish selecting points. (or Right Click > OK) 

 Click to place your dimension String (with the hammer icon) 
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Vertical Dimensions  

 Now use the same principle to place two Vertical Dimensions one overall and 

one giving the geometry and wall thickness. 

 

 

 

NOTE: if you rest the cursor on the side of the wall (getting the trispoke mercedes iron) it 

will highlight the wall and dimension the wall thickness.  

 Simply clicking the corner point of the wall will dimension that point. 

 

Aligned Dimensions  

 Now place an aligned Dimension. You will need to change the Geometry method. 

 Click the top corner of the Angled wall, and then click the bottom corner of the 

angled wall. 

 Double click to finish selecting points, and place your dimension. 

 Make sure the Geometry Method is set to Any Direction, not locked to  

 X-Y Only.  

 

 

 

NOTE: Generally the Geometry Method will be set to X-Y Only as the majority of 

our projects are rectilinear and having an additional choice to place aligned each 

time may slow down dimension placement. 

 

Amending placed Dimensions  

Adding extra points 

 Adding extra points to a dimension string.  

 Select the Horizontal Dimension string. 

 Make sure the Dimension Tool is selected 

 Hold down Ctrl (PC) or Command (Mac) and click either side of the door 

opening. 
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Deleting points 

 Select the node at the witness line/ dimension string intersection you wish to 

delete 

 Hit the delete key. 

 

 

 

Moving points 

 Select the node at the witness line/ dimension string intersection you wish to 

move 

 Choose the first option from the Pet Palette (move node) 

 Click where you want the Dimension string to now dimension 

 

 

Changing the Length of a Witness Line 

 Select the Dimension string 

 With the Dimension tool selected in the ToolBox. 

 Select the node at the witness line/ dimension string intersection 

 Choose ‘Edit Length of Witness line’ from the pet palette: 

 

 Stretch to desired location. 

 

 Alternatively: You could set the Witness lines to be Dynamic Height in the 

Dimension Settings, and set the Dynamic Witness Line Gap. 
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Repositioning Text 

 Select the text and choose move from the Pet Palette 

 Move to desired position 

 

 This can be useful for Wall thickness dimensions, if you drag the dimension far 

enough away an automatic pointer will appear: 

 

 

 

Modifying Text 

 Select the text 

 Open the Text Selection Settings  

 Type in your new text. 

 

 

 You can also ADD superscript or 

standard text, either before or 

after the dimension. 

 Select the text 

 Open the Text Selection Settings  

 Tick to use Custom Text:, Your Measured Value will be added to the Custom 

Text line 

 Type your standard text in front or behind the measured text 

 Use the Insert Autotext button to start and finish 

any superscript text. 

Arc Length Dimensions  

 Choose the Dimension Tool from the ToolBox 

 From the Geometry Method choose, Arc length 

 Select the right side of the lower curved wall. 

 Double click to finish selecting points 

 Click to place Dimension line. 

 

Cumulative Dimensions  

 We can create Running (Cumulative) Dimensions and Base-Line Dimensions by 

selecting the respective Dimension Type from the Dimension Default Settings. 

 

 

 Or by selecting the Construction Method directly from the 

InfoBox  

 Open the Dimension Default Settings and Choose Cumulative Method 

 Chose a more appropriate Marker Type (arrow head style) 
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 Select points along the lower wall, from left to right. 

 Double click to finish selecting points 

 Click to place the Dimension String 

 

 

Angle Dimensions  

 Choose Angle Dimension from the More section of the ToolBox. 

 From the Construction Method, choose Inner Dimension 

 

  

 Use the Status Bar to help you select the correct elements. 

 Select the underside of the angled wall 

 Select the right side of the vertical wall 

 Click to place your dimension text 

 

 

Radial Dimensions  

 Choose Radial Dimension from the More section of the ToolBox. 

 Select the inside face of the curved wall 

 Click to place the dimension text.  
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Level Dimensions  

 Choose Level Dimension from the ToolBox. 

 Click on the square Slab to place a Dimension Marker 

 From the ToolBar activate Gravity and set it to Gravitate to Slab 

 Click on curved Slab (which is 300mm higher than the first slab) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: Gravity can only be used at the time of placement, you cannot select an already 

placed object and use gravity on it.  Gravity can also be used to place objects, Trees can 

Gravitate to a Mesh, Level Dimensions can Gravitate to a Roof.  

 

Once Dimensions are placed and objects have been selected to place the dimensions, 

they remain associated to those objects.  In the case of the level dimension, if the slab 

height changes the text value will alter accordingly.  In the case of a wall/window 

dimension, if the window is moved the dimensions associated to it will update. 

Bach Dimensions (Automatic Dimensioning) 

Having completed the dimensioning exercises you can now dimension your Bach project. 

Instead of placing individual dimension Strings, we can use ArchiCAD’s powerful 

Automatic Dimensioning Feature. 

 Navigate to your Bach file. 

 Navigate to the Ground Floor Plan – use the View Map 

 Open the Dimension Tool and check the following settings 
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 Change to the Wall Tool and select all Walls (Ctrl+A or Command+A) 

 Open the Document > Document Extras > Automatic Dimensioning > 

Exterior Dimensions… dialog 

 Check the following Settings: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click OK 

 Click the North Wall – this indicates the main direction of the dimensions chains 

 Click a point just above the deck – this indicates the position of the first 

dimension chain 

 In some cases the Automatic dimensions may 

need additional editing but it is easier to delete 

items then create them!  

 Use the methods from the Dimensioning Exercise 

to add dimensions to the Carport posts and the 

extents of the North Deck. 

 

We can modify the dimension strings to automatically reposition the text to a more 

appropriate location, for example the wall thickness dimension string. Select it and 

open it setting and change the Dimension Text placement method to Centered 
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Elevation Dimensions 

 We can use the Elevation dimensions in our Sections and Elevations.  

 Open A1 Section AA from the View Map 

 Select the Dimension Tool from the ToolBox 

 In the Info Box change to Elevation Dimension and choose a Marker Type.  

 

 

 Within Section AA we can place some Elevation Dimensions 

 

Cover Fills 

Fills (or hatches) are useful to help define materiality of areas within a floor plan. We can 

place independent fills or we can attach fills to modelled elements – these are ‘Cover 

Fills’ 

 Make sure you are on the Presentation Plan view 

 Select the Slab that defines the deck and the two step slabs 

 Open the Slab Settings and within Floor Plan and Section, tick ON Cover Fills 

 Set the Fill Type to Plank Floor 

 And set the pens accordingly 

 

 

 Click OK 

 This is great for ‘single finish’ slabs like decks etc 

 Select the main floor Slab and apply the following Cover Fill Settings 

 

 

 Click OK 
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As you can see the entire Slab takes on the fill. However, in this case we only want to 

show tiles in the Bathroom, Kitchen and Entry areas. 

 Click Undo (Ctrl+Z or Command+Z) to remove the Cover Fill 

Standard Fills 

Standard 2D Fills also have their place in documentation (& presentation) and can be 

better suited than Cover Fills in many situations. 

 

We’ll create some Fills to represent our tiled floor areas. 

 

NOTE: It is also possible to use 3D Zones to identify floor finishes, we will look at this 

process later. 

 

 Open the Fill Tool Settings and set them as follows: 

 

NOTE: There are two main types of Fills Vectorial and Symbol. Symbol fills are much 

more detailed than Vectorial fills and should therefore only be used for small areas 

of fill – mainly in your detail work. 

 

 

 

 Click OK 

 Place a Rectangular Fill within the Bathroom – you can place this across the 

entire floor as the bathroom objects will block out the fill as they have a white 

background 
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 Place a Polygonal Fill in the Entry / Kitchen Area  

 

 

 

 Start at the Entry, up the Kitchen wall, along to the Bi-Fold doors, down to the 

South Wall, and back to the Entry start point. 

 

 

 

Fills allow you to change the direction and size of the Fill pattern 

 Select the fill in the Kitchen 

 Change the Origin Setting using the Info Box (you will need to scroll the Info 

Box) 

 

 You will see a ‘handle’ appear – rotate the handle 45 degrees 
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Text  

For our Floor Plans we can use the Standard Text Tool to identify the various Rooms. 

NOTE: 3D Zones can also be used to label spaces, we will look at this later. 

 Open the Text Tool Settings and set it as follows: 

 

 

 

NOTE: Text is input at the real size it will output as (Paper Size), for example 5mm text 

is 5mm when printed – because of this text appears to grow and shrink when the drawing 

scale changes – for this reason it is important to set the anchor point for text correctly so 

if the drawing scale changes the text still remains in the right place. For the room names 

we want them to stay centred in the room. You can choose to place Text at Model Size. 

 You can use the Create Guide Line Segment command to place Guide Lines 

diagonally across the Master Bedroom 

 

 

 

 Double click the mid-point of the Guide Line to place the text in the Centre 

 

 

 Type the name: Bedroom 1  

 Click outside of the text to complete 

 Repeat for the other rooms, Bedroom 2, Bath 

 Label the Kitchen and Living Area separately 

 Label the Entrance 

 And finally the Hallway 
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For Text placed over Fills you will notice there is an opaque background, this is because 

Opaque was ticked. 

 

 

 

Labels 

While annotating the various drawings it is important to label items and have a leader line 

indicating what the label refers to. You can do this with the ArchiCAD Label Tool. 

 Open the Label Tool Settings and set them as follows: 
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NOTE: When placing a Label (1) the first click is where the leader’s arrow head will be 

placed, (2) the second sets the vertical offset of the leader, (3) the third indicates where 

the text box starts, (4) and the final click the size and shape of the text box. (The third 

click can be a double-click, and this will place an automatic sizing text box) 

 

 Place a label for the Pergola Post “90x90 H3 Timber Post” 

 

 Place a label referring to the deck “90x45 Radiata Decking” 

 

 Place a label indicating the Roof outline “240x45 Timber Beams” 

 

 

There is a nice option to align labels 

 Select the 3 placed lables  

 Choose the Adjust tool from the Toolbar 

 Draw a vertical line to adjust them to. 

 

 

In some cases you may wish to have multiple leader lines from the same piece of text. 

An alternative to ArchiCAD Labels is to use the Text Tool and the Polyline or Spline Tool 

with an arrowhead added. 

 Select the Polyline Tool and open its Settings 

 

 

 

 Choose the Arrow at start option 

 Choose your arrow head type 

 

NOTE: The same arrow options are available in the Line and Spline Tools. 
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Module 10 – Two Story Bach 
Having produced a simple one story bach the client has decided they need more space – it’s 
time to go up. 

In this module we add a top floor to our bach. This will involve the creation of some new 
elements along with some editing to the existing bach. 

We’ll also have a look at Stairs to ensure we can access the top floor 

Story Settings 

 Open the Design > Story Settings… dialog 

     

 You’ll notice that the project template does not contain a First Floor 

 

 

 

 Rename Roof to First Floor (as the lower roof will now belong to the First Floor) 

and add a new roof Story using Insert Above, label this as Roof 

 In the Height to Next field for the Ground Floor change the 2450mm to 2710mm 

(this allows a 2450mm Wall, 240mm Joist and 20mm Particle Board) 

 In the Height to Next field for the First floor set this to 2450mm 

 Tick the Story level box to the right of Ground Floor and First Floor, this allows 

the story level markers to show in section and elevation 

 Click OK 

 The Project Map will now 

show the renamed and new 

Stories 

 You can always see what Story 

you are currently on, as it is 

shown Bold in the Navigator 

 

BIM Note: 

The BIM environment consist of a series of Levels (called Stories)  In 

ArchiCAD information is placed associated to a Story, if that story is moved 

(up or down) the information on that Story moves too.  Also if the Story is 

deleted ALL the information on that story will be deleted too! 

 

Subtly the Roof elementhas changed elevation – because we moved the Roof 

Story up 260mm, and all elements on that Story move up. 

 

Roof Editing 

 Go to the Section View and measure the spring height, previously this was 2450… 

 

 

 

 Select the Roof, open its settings and change the height to -260mm 
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 This will set the roof back to its correct pitching height of 2450mm from the 

Ground Floor. 

Top Story Walls 

The top floor Walls are a simple rectangle of Walls placed directly over the top of the 

Kitchen and Living part of the bach. 

 Select the First Floor from the Project Map, you should still be able to see the 

Ground Floor walls as a Reference. 

 If not turn the Trace reference back on with the icon in the ToolBar. 

 

 

 Use the Eye Dropper to ‘pick up’ the attributes of the Exterior Walls of the living 

area below (yes you can use the Eye Dropper on Reference elements!) 

 Ensure the Wall Geometry method is set to Rectangular 

 

 

 Making sure you get the appropriate cursor symbols draw a set of Walls directly 

over the Ground Floor Walls (initially you will get a Tick cursor to indicate the 

exact corner point; once drawing the Walls you need to ensure you get a Black 

Pencil cursor to indicate you are directly over the Ground Floor Walls.) 

 

 

 

 

 

 

 

Mid Floor 

 Open the Slab Settings 

 Set the Structure type to Composite and choose the composite called Floor: 

Joists 240 + 20mm Ply B/L 
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 Set the Height to Home Story to 0 

 Within the Model tab, Override the top surface with Carpet - 01 and the edge 

with the same surface as the exterior walls; Siding - Light. 

 Click OK 

 Ensure the Slab Geometry method is set to Rectangular 

 And trace the same shape as the walls you just placed. 

Top Story Roof 

 Select the Roof Story from the Project Map 

 

 

 Open the Roof Settings, for the top Storey we are going to construct a Gable end 

Roof. 

 Set the Structure to Basic and choose the Building Material Timber – Roof 

 Change the Geometry to Multi-plane. 

 Change the thickness of the Roof to 90mm and the pitch to 15º 

 In the Multi-plane Geometry settings set the Eaves overhang Offset to 450mm 

Layer should be Des: Roofs 

 In the Info Bar set the Construction Method to Gable 

 

   

 

 Draw a rectangular roof snapping to the same points as your mid floor slab.  

 The Multi-plane Roof will automatically extend the eaves. 

 Goto 3D, select the First Floor Walls and the First Floor Roof  

 Use the Design > Connect > Trim Elements to Roof/Shell… command to trim 

the walls.  

 A dialog will pop up – Click Trim 

 

 

 

NOTE: You can easily change this roof to a Hipped roof. 

 

 Select the Roof, click on the edge blue pitching line, from the Pet Palette choose 

Custom Plane Settings 
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 In this new dialog change the Plane type from Gable to Pitched 

 Click OK. 

 

 

 

 Hit Ctrl+Z or Command+Z to Undo this. 

Ground Floor Editing 

If you look at the model in 3D you can see it taking shape but you may notice it isn’t 

exactly correct! There are a few elements on the Ground Floor that need to be edited. 

 

 

 

     Roof Editing 

With an upper floor there is no need for the lower roof to cover the entire bach 

 Go to your Ground Floor Plan View. 

 Select the Roof (remember it is best to be on the Roof Tool to make selecting 

Roofs easier) 

 Use the Pet Palette to adjust the shape of the Roof so that it only covers the 

bedrooms, bathroom and carport, and fit nicely around the First Floor Walls. 

 

 

Wall Editing 

If you flip to 3D you will notice the Ground floor walls seem to have disappeared. 
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These walls are ‘still’ connected to the roof we just edited – and with no roof to connect 

to, they disappear in 3D but are still visible in 2D. 

 

 

 Select the five Walls that sit below the upper Walls 

 

NOTE: The top right of the Settings dialog says Selected: 5 Editable: 5, this means 

you have selected 5 walls. 

 

 To unconnect the walls from the roof, Right click > Connect > Clear All 

Connections 

 

 

 

 Now the walls are unconnected but very tall. They will have a 2000mm top offset. 

 Open the Wall Selection Settings 

 

 

 

 Set the top height back to 0 

 Flip to 3D 
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 Note Wall 5 is poking through the lower roof. 

 It needs to be Split at the hallway! 

 To split, select this Wall (in Plan), choose the Split tool in the ToolBar 

 

 

 

 Click where you want the Split to occur. 

 

 

 

 Flip back to 3D. 

 Trim this to the Roof – select both the wall and the roof plan, Right-Click > 

Connect > Trim Elements to Roof/Shell  

 

 

Stairs 

With an upper floor it is important to be able to access it! You can add Stairs to the model 

using Cadimage Stair using the Polystair Tool 

BIM Note: 

Stairs are geometrically very complex, and some stairs more so than others.  With 

Stairs, create an accurate stair with regards to treads, rise and generic style.  The 

extra detail can come later in the 1:20 stair detail drawings.  

 

 Open the Polystair Tool Settings Dialog. Select the Cadimage Stair on 

Stringers 

 From Favorites… apply the Favorite Timber Stair NZE 

 Set the Home Story to 1. Ground Floor 

 Set the achor point (start point) of the stair as below: 
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 Open the tab, Cadimage stair on Stringer – Settings, and in the Structure 

Tab, set the Total Rise of the Stair to 2710 as this is the Floor to Floor Height. 

 Set the Width to 900 

 From within the FLOOR PLAN DISPLAY Set the Show on Stories to Home & 

One Story Up  

 Set the Layer to Des: Fittings General  

 

 

 

 

 

As this stair is a ‘Main Private Stair’ we know the min tread is 280 and the max rise is 

190. We can set our stairs to have a fixed going of 255 (255 + 25 Nosing = 285 to be 

save) 

 

 In Flights + Landings, set the 1. Flight to 255mm  

 And make sure it is locked. 

 

 

 

 Place the Stairs anchor point at the end of the south window and align it to the 

wall, draw a stair of 1275mm long 

NOTE: The Pet Palette should default to Flight type 

 

 

 

 

 

  

  

 Change the Pet Palette to Landing type 
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 Click into the wall corner 

 Place the second part of the landing, 1255mm UP from the corner. 

 Change the Pet Palette back to Flight Type  

 For the final flight click up the wall around 2000-2200 (the stair will always snap 

to the last 255 going) 

 To Finish the Stair you need to click on the ‘X’ at the end of the stair. 

 

 

 

 

 

 

 

 

Automatically the breakline will be displayed in the centre of the first flight, click the mid 

point editing node of the break line and adjust it clicking the ‘move node’ option in the 

Pet Palette. 

 

 

NOTE: We can check that we have the required riser height by selecting the stair and 

within Structure, we see our riser height = 181 (which is less than 190 max) 
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Stair Railing 

 Select the Stair and go to Cadimage > Stairs > Place Railing… 

 Select the Favorite Handrail NZE and check its height is 1000 

 Ensure the Layer is set to Des: Fittings General and click OK  

 

 It will zoom into the stair and you can 

click on the outside of the stair to 

place: 

 

 

 

 

 

 

 

 

 

To see the resulting staircase place a Section through the Stairs 

 Open the Section Settings and select the Section Model Pens NZE Favorite 

 Start the Section line about 1000mm to the left of the stairs and about midway 

through the Stairs 

 Draw a horizontal section line that cuts the Stairs in two and finishes about 

1000mm beyond the right hand exterior Wall. 

 

 Open the Section 
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Stair Floor opening 

Having placed a set of stairs a hole needs to be cut in the First Floor Slab. 

 Go to the First Floor (double click First Floor in the Project Map) 

 Select the Slab (if you are on the Slab Tool this makes selecting Slabs easier) 

 With a Slab selected; drawing a polygon within the Slab boundary tells ArchiCAD 

to cut a hole in the Slab if you have the Slab tool activated. 

 Set the Geometry method to Polygonal, and trace around the Stairs (you will get 

Tick cursors and Black Pencil cursors to indicate you are snapping to the Stairs) 

 

 

 

You can also re-size the opening so that it is just right for our Head plane compliance by 

further editing the First Floor slab. To check to clearance; 

 Open your Stair Section 

 Select the stair and within Symbol > Head Clearance you can trun ON your 

Head Clearance plane (this is a 3D glass plane that will show in any view) 
 

 
 

 Measure the distance from the edge of your ‘hole’ to the stair height plane 
 

 
 Back in the First Floor Plan, select the Slab, and click on the ‘hole’ edge 

 From the Pet Palette choose ‘offset edge’ 

 And type 317mm 
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Interior Walls 

 Open the Wall Settings and select the INT: Stud 90 Pb NZE Favorite 

 Set the wall height to link to Home + 1 

 

  

 

 Go down a story to the Ground Floor (use the shortcut key Ctrl+F2, Ctrl+down 

arrow or use the Project Map) 

 Draw a wall that runs along side the Stairs 

 

NOTE: The window we placed in the East wall now conflicts with the new wall, 

Select this and delete it. 

Solid Balustrading 

 Go up a story to the First Floor  

 Open the Wall Settings and change the Wall Top linking & height to 1000mm 

 Set the Floor Plan Display to Projected (this will mean the wall will not display 

as being cut) 

 

 

 Draw a wall along the topside of the Stairs to form a balustrade Wall 
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 Use a Marquee to just show the Stair area in 3D. 

 

NOTE: that you can see a weatherboard pattern on the edges of the hole we cut for 

the stair.  This is because we set the edge Override of the slab to match the wall 

cladding earlier. This can easily be changed. 

 

 Select the Slab, then click on the top edge of the hole. 

 From the Pet Palette choose Custom Edge Settings 

 In this dialog set the Surface to Paint - Titanium White, and apply to Selected 

Polygon. 

Further First Floor editing 

We want to pull the floor back to provide a double height space over the Kitchen. 

 Back in the First Floor Plan, select the Slab 

 Make sure the Trace Reference is On.Cut a hole in the Slab following the inside 

face of the kitchen walls up the the jamb of the Bi-Fold door below. 

 Click on the edge and change to Paint – Titanium White (like the Stair hole) 

 Place a Railing.  Go to the Railing Tool, choose Cadimage Railing 

 Choose the 

Cadimage 

Horizontal Rails 

and set it Linear 

Graphic editing 

 Place the Handrail 

on the First Floor 

and stretch into 

position:  

 

First Floor Windows 

 Place your own Windows to the First Floor. You can ‘pick up’ the attributes of the 

Ground Floor windows or dream up your own. 

 Once finished check out the 3D Views and the Elevations 
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Module 11 –Scheduling & Lists 
This module explores ArchiCAD’s ability to schedule the elements placed. 

Firstly we’ll look at the Cadimage Door+Window Schedule 

Then the built-in Interactive Schedules, specifically a Wall Schedule. 

Finally we’ll look at the Zone Tool. The Zone Tool provides a large array of quantitative 
detail. We’ll scratch the surface by looking simply at the area measurements that the Zone 
Tool can help with. 

Creating a Door & Window Schedule 

Regardless of whether you use solely Cadimage Tools Doors & Windows, ArchiCAD 

Doors & Windows or a combination of both, the Cadimage Door & Window Scheduling 

can Schedule your openings. 

 Navigate to the Ground Floor Plan View 

Notice that there are are some duplicates window numbers which is caused by picking 

up the properties of windows, and they will most likely not be in the correct order. 

 

Setting Unique ID’s 

The Schedule itself is very quick to create, but as with anything BIM, the information that 

is displayed is only as good as the information available.  To this end we can turn on the 

Window and Door Markers and see if they are what we want to see. 

 

 Select all the windows – Have the Window Tool selected and hit Ctrl+A for PC 

or Command+A for Mac 

 Open the Element ID Manager – Document > Schedules and Lists > Element 

ID Manager...  

 Choose Window ID in the Settings box 

 Under ID Format, set the first two format boxes as shown, and set the second 

two to Not Used 

 Hit Change ID’s... 

 Repeat the ID setting for the First Floor except set the ID Text Component to F.  

(G for Ground, F for First) 

 This will now give all the selected Windows a unique ID. If you are not happy with 

the order of these you can manually override them. 

 

BIM Note: 

As with most automated processes, the result is accurate, but may not be 

what we are used to.  Be sure that the automated process is NOT acceptable 

before you break it and manually override.  Ask yourself if it is really that 

important that all your external openings are numbered sequentially . . . what 

happens if you add or remove a window further down the track, do you 

renumber ALL your openings just so that they are in order? 

 

To manually adjust the Window numbers, select a Window and open its Selection 

Settings. 

 Under Listing and Labelling, change the ID: 
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Create a Schedule 

 Got to the Cadimage menu, Doors+ Windows > Schedule Settings 

 Click Create New... ID: SH-01 and Name: D&W Schedule, then OK 

 

 

 

 Under Criteria, tick both Doors and Windows and turn ON Collate and tick to 

Isolate Mirrored (this will look at the Windows and Doors and group all similar 

items except Mirrored items)  

 

       

 Under Layout set Master Page Size to A1 (as this will be our eventual output 

paper size)  

 

   

 

 Under Dimension set your Dimension Style 

 

   



INTRODUCTION TO BIM   

Introduction to BIM   Page 101 of 166 

 Under Labels set to Show Element ID (Window Number) and Additional Notes 

 Click OK 

 Now go to the SH-01 D&W Schedule Worksheet in the Project Map. 

 

   

  

 

The Schedule displays the Openings in Alphanumeric order, and set out as per the 

Layout Tab settings. 

 

 

Notice that there is a dimensioned Empty Opening.  This can be removed using the 

Filters in the Schedule Settings. 

 Navigate to the Ground Floor 

 Select the an empty opening and open its Selection Settings 

 Under Tags and Categories set the ID to EMT01 

 Click OK 

 Navigate back to the Schedule Worksheet 

 Hit the Settings button in the floating Schedule Palette 

 Under Criteria tick Element ID 

 In the newly opened dialog Add a Filter > Element ID > Does Not Contain > 

EMT 

 Click OK 

 

 

 

 Click Close to close the Schedule Settings 

 Back in the Schedule Worksheet, the Empty opening will disappear. 
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BIM Note: 

As this Schedule is a ‘Result’ of your BIM model, if you add new Windows, or 

Delete windows, all you need to do is Update your Schedule by going to 

Cadimage>Doors + Windows>Update Schedule which will refresh with this 

updated information. 

 

 

Window ID’s in Elevation 

We can get our new Window ID’s to Show in Elevation 

 Open the Label Tool, select ID Label and turn off the Pointer  

 Set the Anchor Point to centre 

 Set the Layer to Doc: Elevations 

 

 

 

 Navigate to the North Elevation in the View Map. 

 Ensure that the Window highlights as you hover your mouse over it 

 Click to place the ID label in Elevation 

NOTE: Be sure to set your Model View Options to a Model View that has the 

Window Marker ON  

 

 

 

To get all the Labels to align select all the lower storey labels and go to 

Edit>Align>Centre Horizontally 
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Element Lists 

ArchiCAD has powerful in-built Interactive Schedule that can interrogate your BIM model 

and provide tabulated results. 

 

We can make a basic wall Schedule to give us wall type, wall length and wall area. 

 

 Within the Project Map, go to Schedules > Element > Wall List 

 The List of all Walls in the Project is displayed 

 Within the Scheme Settings (top right) we can customise the List 

 As we only want Wall Type, Wall Length and Maximum Height, we can remove  

 Net Volume 

 Thickness 

 Height 

 Maximiun Height 

 Area of the wall (this is the Floor Plan Area) 

 Perimeter of the wall 

 Click OK 

 

The resultant list displays the wall type, its reference side length and height. 

 

 

You can select a Wall from within the Schedule and find it on the Plan or in 3D. 

 Select the bottom wall in Wall Type EXT: Stud 90 (10,800) 

 Hit the Show on Plan Button or 

 

 Select the Show in 3D Button  

 

Surface Schedules 

 

There is a Surface Schedule where we can find out our surfaces for cladding and paint 

requirements. Scroll down in the Project Map and double click the Finishes by 

Elements Surface Schedule 

 

Scroll down the list to see a list of the Walls: 

 

 

The checkbox on the right column shows us whether the Surface has been overridden 

from its default option. It is turned on for Wd Siding Light Vertical as we modified the 

external walls from white to board & battens. 

If you select a Surface you can modify it within the Surface Interactive Schedule and this 

will affect the model. 
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This surface area can be affected by other elements that may be covering it in the model, 

to control what affects the surface area click Scheme Settings in the upper right corner. 

Expand the Fields section and click the small icon beside Exposed Area: 

 

This means that the kitchen cabinetry will exclude its surface area from the internal side 

of the bounding walls. 

Zones 

The Zone Tool is a modelling tool as it allows 3D blocks to be created and viewed in 3D. 

These blocks can be used for space planning as they contain a huge array of 

quantitative data (area, volume, surface area of walls, number of openings etc) 

In its simplest form Zones are useful as they provide a Room Stamp to label the room 

and also provide simple area calculations. 

 Open the Zone Tool 

 Check the following settings are correct: 

 

 Click OK 
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 Make sure you are on the Presentation Plan View 

 Starting at the left hand end of the bach you can add Zones to each room. 

 The Zone Tool has three placement methods: 

 

 

 The first allows you to draw the required shape (similar to the Slab Tool) 

 The second automatically places the Zone based on finding the Walls 

that define the room. In this case the zone is placed to the inside face of 

the Wall and therefore provides the Net Floor Area. 

 The third is again automatic, however this time it places the zone to the 

reference edge of the Wall and therefore is useful for Gross Floor Areas 

 

 Make sure you select the second method (Inner Edge) 

 Now simply click within the left hand bedroom 

 Your cursor will change to a Hammer 

 Clicking again places the Stamp (Room Name and Area) so place this 

approximately in the centre of the room 

 Note you may be prompoted to Show Layer if your not on Presentation Plan. 

 

 

 

 

 

 

 

 

 

 

 Repeat this for all the Rooms on the Ground Floor 

 The Room Number automatically updates but you will need to change the Name 

of each room before you place the Zone – to save opening the Settings Dialog 

you can use the Info-Box to change the name 

 

When placing a Zone that is not bounded by walls you need to add a Zone Boundary 

line. 

 Open the Line Tool, set the settings as per below: 
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 Draw a Zone Boundary Line from the edge of the Bi-Fold door to the opposite 

wall 

 Re-open the Zone Tool, set the correct Name, Fill type etc and place a Kitchen 

Zone, then a Living Zone. 

 Move to the First Floor and place a Zone for the Studio 

 You will notice the Kitchen void and stairs have been included in both the Ground 

Floor and the First Floor – Undo the Zone Placement 

Add new Zone Boundary line at the top end of the Stair 

 

 Update the Zone using Design > Update Zones 

 

 

Zone Listing 

Having placed a series of Zones we can get ArchiCAD to list the Zones along with the 

areas and even provide totals 

 Making sure the Navigator is set to Project Map, double click the Schedules > 

Element > Zone List item 

 A dialog will be displayed showing a table of data 

 

 

 

 The table lists the Story the Zone resides on, the name of the Zone and it’s Area 

 A subtotal is provided for each story and a grand total is provided at the bottom 
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Module 12 – More Model Detail 
This module explores the ability to add more detail to the model.  

We’ll look at Cadimage Coverings - Roof Coverings and Wall Coverings to add more 3D 
information to the model. This detail helps add realism to the model but has the added 
benefit of adding more detail to the section drawings. 

 

BIM Note: 

Using Cadimage Coverings we really start to see the power of BIM.  Based on 

the simple ArchiCAD geometry we can easily add the additional elements that 

show the true construction of the building (purlins, fascias, soffits, wall 

cavities andactual weatherboards). These elements not only add to the 

visualisation of the project but also add detail to the section views. 

Roof Coverings 

The Cadimage Roof Coverings attach a special object to a Roof to provide additional 

detail. 

 Make sure you are on the Roof Story 

 Select the upper Roof 

 Select Cadimage > Coverings > Roof Coverings… 

 Select the Cadimage Roof Covering Object 

 Within Preview and Positioning make sure the Home Story is 3.Roof (Current) 

 Choose Edge Types > Default Settings 

 We have a Gable End roof so set the Roof Type to Hip/Gable 

 

 

 

 

 Within Floor Plan and Section, set Show on Stories to All Stories 

 Set the Layer to Des: Roof Coverings 

 

 Set the Cladding type to use the Preset named Ribbed 

   

 

 Within Edge Boards set the Fascia as below 



    INTRODUCTION TO BIM 

Page 108 of 166                Introduction to BIM    

 Within Soffits set the Type to Sloping and the width to 450 

 

    

 Click OK 

 Select the Lower Roof apply a similar Roof Covering, just Change the Home 

Story to 2. First Floor 

 the Roof Type to Monopitch 

  

 

 And the Soffits to deeper for the deeper rafters – 190 x 20 

 

 

 Select the Roof Coverings and change their Display Order to Front, so that it 

‘covers’ the pergola rafters. 

Downpipes 

Place downpipes by selecting the pink downpipe hotspots at the edge of the 

gutters, selecting Stretch from the Pet Palette and dragging the downpipe into 

the desired location 

    

 To adjust the downpipe length, open the 3D and select the pink hotspot at the 

base of the downpipe (nearest the wall) then select move node from the Pet 

Palette 

 

 Notice also that the Roof now has Barges, Eaves, Fascias, Gutters and Soffits 

 Navigate back to the Ground Floor and see that the downpipes are showing 
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Wall Coverings 

In the same way as Roof Coverings apply to Roofs, a Wall Covering Tool is available 

to apply sophisticated objects automatically to Walls. 

 

The Wall Covering Object provides a comprehensive array of Wall Claddings that 

can be applied. The principle is exactly the same as the previous Coverings. 

 Navigate to the Ground Floor 

 To make the selection of the required Walls easier we’ll use the Find and Select 

tool 

 Open the Edit > Find & Select … dialog (Ctrl+F PC and Command+F Mac) 

Find & Select allows multiple criteria to be set for selection purposes 

 Make the following settings or just pick up the properties of a wall. 

 

 

 

 Click the + button to select the four leftmost exterior walls 

You don’t need to close the Find & Select dialog as you’ll use it again shortly – you may 

want to move it away to the side though 

 With the walls selected go to Cadimage > Coverings > Wall Coverings... 

 Select the Cadimage Wall Coverings Object 

 Within the Cadimage Wall Coverings - Settings > Covering Layout > Shape, set  

the Wall Base Shape to Flat and to Offset Down 50mm 

 Set the Layer to Des: Wall Coverings 

 

 

 

 Set your Cladding Type 

 Go to Coverings  and choose Board & Batten with the following Parameters 
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 And since its Vertical set the spacing of Board & Battens to 600 

 

 Click OK 

 The tool then needs you to indicate which face of the Wall to attach the Wall 

Covering Objects to – click on the Outside 

 De-select all elements 

 View the results in 3D 

 

We’ll now repeat the exercise for the remaining Exterior Walls 

 Use Find & Select and pick up the properties of the other external walls. 

 

 With the walls selected go to Cadimage > Coverings > Wall Coverings... 

 Within Coverings set the following parameters for our Horizontal Weather 

Boards (or simply use the Preset named Weatherboards) 

 

NOTE: We have told the cladding to start 50mm down from the base of our wall, but we 

have not set that we want our first full board to start 50mm down aswell.  To do this:  

 Within the Coverings tab, use the Pulldown and select Cladding Reference 

Origin & set this to 50mm below Ground Floor (i.e. -50). 

 

 

 

We can also change the Surface materials 

 Within Coverings choose the Surfaces Paint Bruch icon, change the Paint 

finish to Paint-Light Gray 

 

 

 

 Click OK, then click to place your Weatherboards. 
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We need to apply cladding the First Floor as well. 

 Navigate to the first floor and Select the Exterior Walls & go to Wall Covering 

 For the First Floor we are going to use two different cladding types, plus we also 

need to cover the First Floor Floor Structure. 

 In Covering Layout > Regions, set the region to Split at Head Height and set 

the head height dimension to 2200 

 

 In Covering Layout > Shape set the offset to the thickness of the Floor i.e. 260 

We now need to set the new cladding style (the cladding above our 2200 height) 

 Navigate to the Coverings > Above Head and choose our Board & Batten 

Cladding Type 

 

 Then click the Surfaces icon and change the Board + Batten to Paint Sand Beige 

 

 

 

 Now we should have a complete model! Click OK and place the Coverings 

 

Note that the cladding continues continuously between the two pieces of wall cladding, 

this is because the Cladding Reference Origin was set to 50mm down from Ground floor 

for both. 

  

 

 

Wall Coverings add another level of detail to the model allowing elevations to be 100% 

from the Virtual Building Model. 
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Module 13 – Sections and Details 
This module looks at how to create Sections and Details for Contract Documentation. 

Two working methods are outlined for Sections, which when combined provide you with the 
arsenal required to create top quality sections. These methods are: 

Masking, and 

Overlays 
 

Remember the aim it to rely on the model to maximum extent possible and draft the 
minimum as possible. 
 
While examining details we also show how to make use of external data to the best extent 
possible. 

Sections 

We will look at Section AA and experiment with a few items to show the concepts to 

‘spruce up’ your section to working drawing level 

 Use the View Map to open up Section AA 

 

 

 This section is still fully modelled, so we can still make changes to the modelled 

elements. 

 Zoom into the left foundation and stretch it down. 

 Select the Beam, click on one of the bottom corners, and from the Pet Palette 

choose vertical stretch 

 Move your mouse in a downward direction and type in 800 

 

 

Because of ArchiCAD’s Priority Connection clean-up, the slab insulation, sand blinding etc, 

has been ‘cut-away’ with the foundation beam.  And because the foundation beam has the 

same main building material, the contour line between the two has been omitted. 

 

You can see the Floor Slab and Foundation have cleaned up the fills have merged to 

display a “single pour of concrete”.  

 

We can use Display Order to make elements ‘appear’ to cut one another as well. 

 Select the Earth (i.e. the cut Mesh) 

 Right-click and select Display Order > Send Backward 
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Masking 

In addition to using ArchiCAD Intelligence to clean up sections, you also need a couple 

of further techniques – the first of these is ‘masking’. 

 

In some cases standard Layer control (i.e. switching Layers On and Off) doesn’t provide 

enough flexibility. 

 

We can use 2D fills on top of our Section to add this additional detail. 

 

The fills won’t only mask out the unwanted information, but also provide graphical 

information. 

 

 We can add some additional backfill under our slab. 

 First let’s see what fill to use, Select the Slab, right-click and choose Edit 

Selected Composite… 

 Click on the backfill skin and the Building Material is displayed ‘Gravel’ 

 Open the Fill Tool 

 Set the Fill Settings as follows: 
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 Using the Polygonal geometry method, place your Fill under the Slab. 

 Then Use Display Order to bring it forward 

 

 

 

Overlays 

Overlays are used to add further detail to a Section or detail that is too difficult or 

impractical to model (or you have certain time constraints). Where possible it is best if 

overlays are intelligent 2D Objects. 

 

 The Cadimage Detail Element Tool provides quick access to a suite of smart 

overlay objects.  

 Select the Detail Element Tool from the Document part of the ToolBox. 

 

 

 

 Navigate to the 03 Walls subfolder and select the Cadimage Wall Frame 

Section object.  

 

 

 Make sure the layer is set to Doc: Sections  

 There is also a prompt for the best placement method, in this case the best 

Geometry Method is Rotated Diagonal 

 

NOTE: There are many settings, once your settings are chosen, you can Save them 

as Presets (or Favorites) so that you can use them again in other projects. 
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Our default settings are for 90x45 timber framing, with plaster board lining on the right 

and insulation within. 

 

 Click OK, and change your Geometry Method to Rotated Diagonal. 

This particular detail element places from its bottom right, so we need to find an 

appropriate start point.  Let’s start with the left wall. 

 

 Zoom into the top of the left wall and activate a guide 

line at the interior framing line (click on the orange 

ball) 

 Now pan to the bottom of the wall and click on the 

guideline/slab intersection. 

 Next click is the direction – so click vertically up the 

wall. 

 Next click is the height (length) so click at the wall top. 

 

 The framing will fill in to the height of the wall. This wall has an opening in so we 

need to edit the overlay object to show this.  

 Select the object, you will notice that some of the hotspots are purple dynamic 

stretchable hotspots. Select the upper hotspot, make sure you have the stretch 

option in the pet palette selected and stretch the hotspot up. In this case we 

know the window head is at 2200 so type this into the tracker box. 

 

 

 Repeat the same exercise for the sill hotspot, in this case the opening is a door 

so set the sill to 0 in the tracker box. 
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 With the right hand wall, again start at the bottom right corner and stretch up to 

the top of the wall. Tip; you can also type 2450 into the Tracker as this was the 

wall height we started with. 

 The ribbon plate and lining will default to the right hand side of the wall.  Which is 

not what we want. 

 

 

 

 Select the Wall Frame object and bring up its Settings. 

 We need to change the ribbon plate position and wall lining to the left hand 

side. 

 

 

 

 

 

 

 

 Within Framing > Members, change the image on the right 

 

 

 

 Within Linings, change it to Line Left Side Only 

 

 

 

 And set the Wall Frame to have to Opening 
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 Next open the Detail Element Tool again and browse to the folder 05 Ceiling 

and select the Cadimage Ceiling Battens object. 

 

 

 

 As our ceiling is sloping we will choose to use the Rotated Diagonal Geometry 

Method. 

 

 

 

 Start at the inside top corner of the framing and set the angle, then stretch to the 

required length, ie the top of the opposite wall. 

  

 

 

 

 The Cadimage Detail Element Library provides a huge array of Objects 

specifically designed for detailing up Sections as well as details as we’ll see next. 

 

BIM Note: 

Using the Cadimage Coverings for 80% of the real modelled elements and 

Cadimage Detail Elements to represent the remainder, we can add a few 

Overlay Fills and label text and we have a Section ready for our Local 

Authority Working Drawings 
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Details 
An essential part of all documentation are the construction details.  You can either create 

a new detail, modify an existing detail, or import a completed detail. 

 

BIM Note: 

The Detail Markers perform the same function as the Section & Elevations 

Markers in that they take a view of the Model and allow us to add additional 

information.  Unlike the Sections and Elevations, changes made to a Detail 

does not update the BIM model.   

 

This is because typically the detail is ‘exploded’ so that we can show thin 

items like Building Paper, DPC, flashings etc.  Each element is seperated by a 

few mm. If when we moved the bottom of the wall 6mm to add the DPC 

between the bottom plate and the slab or moved to roof up to add the Vapour 

Barrier this would adversely modify our construction dimensions.  This is 

why the detail is an abtracted view of the modelled elements with the addition 

of further elements.  

 

Create a New Detail  

 Make sure you are still in Section AA 

 Open the Detail Tool Settings dialog and review the settings: 

 

Note: Make sure the Marker references to The first placed drawing of the 

viewpoint.  This means that ArchiCAD’s automatic numbering will assign the Marker 

to the first drawing placed on the layout.  You will also notice that until this happens 

the Marker text will read #DrgID (this will be the drawing number on the Layout 

Sheet) and #LayID (this will be the number of the actual Layout Sheet). 
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 Use the Rectangular Placement method: 

 Draw a rectangle over the right hand Soffit area 

 Click the top right corner to place the Detail Marker 

 

 

 

ArchiCAD Details take a snapshot of the Model Data and places it in a new window to 

allow further editing. Editing the Detail does not transfer back to the model – this 

allows details to be exploded without destroying the model. 

 

If the model changes, the Detail can be updated with the latest model data by right 

clicking in the Detail and hitting Rebuild from Source View. 

 

 Switch to the Project Map, under Details 

you’ll see the new detail listed 

 

 

 

 Double Click the item to open the Detail in a new Window 

 

 

 It is a good idea at this point to rename the Detail so that it is called what it 

represents, in this case we will rename it to Lower Eaves.  Remove the ID as 

this is not needed. 
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 Change the Drawing Scale to 1:5 using the Quick Options 

 

 

 All data has become drafting based elements (lines, fills etc) 

 A good tip at this point is to drag a copy of the detail data to the side and use 

this copy of the detail drawing, this was if the model changes you can rebuild the 

detail window without modifying you completed detail. 

 It is normally a good idea to Select All Fills and delete them 

 And Select all the Lines and run the Line work Consolidation, Edit > Reshape > 

Linework Consolidation...  

 You can also delete the dashed boundary and clean up some of the lines.  

 

 

ArchiCAD Details retain important model related information 

 Use the Elevation Dimension Tool to place a dimension to the top of the Top 

Plate 

 

 

 

  

The concept with details is similar to the Section Overlay Technique – use the model 

for context and overlay a series of Intelligent 2D Objects from Cadimage Tools Rapid 

Details. 

Modify an Existing Detail  

 Alternatively you can use details that you have already created. 

 Open the Finished Bach File – check Launch a new instance of ArchiCAD 

 Open the Detail Lower Eaves  
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 Use the Zoom to Extents (or double-click the wheel on your mouse) 

 

 You will notice beside the original detail (on the left) is a complete detail 

 

NOTE: Working methods for detailing vary, sometimes it is best to redraw the detail 

beside the model data – this is especially applicable when you use details from previous 

projects 

 Zoom in on the Detail on the right and look at the various objects and elements 

that have been used and explore their settings 

 

You will find two white fills beside the break lines which are Detail Elements. 

As this detail is generally what we want, rather than redraw it in our current 

project you can simply Copy & Paste it, then modify it. 

 

 Select the Arrow Tool and draw a box to select all the elements that form the 

detail 

 

 

 Use Ctrl+C or Command+C to create a Copy on the Clipboard 

 Switch back to your own Bach Project  

 Make sure you are in the Lower Eaves Detail window 

 Click Ctrl+V or Command+V to Paste the information 

 You will see a dialog as follows: 
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 Click Paste 

 Do a Zoom to Extents and you will see the original detail from the Model and 

the detail just pasted 

 Zoom back in on the complete detail 

 Save a View for the Detail with the following settings: 

 Using Current Zoom means that when the View is placed on a Layout it will be 

cropped to the Current Zoom – therefore you will only see the complete detail 

and not the other cutting from the model 

 Use the Organizer to create a new Layout & place the new cropped Detail on it 

   

 Use the View Map to open up Section AA 

 You will notice the Detail Marker now updates to show the Layout Number the 

Detail is placed on, and the Detail number from the Layout Sheet. 
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 Switch to the Layout Book and move the Detail Layout to the top of the list 

 View the Sections Layout and check the Marker – it has updated and displays 

the correct Layout Number 

 

 

 Click Ctrl+Z or Command+Z to undo the change (the Detail Layout moves back 

down the list) 

       

Adding Details from Others 

Details may not always be created in-house.  They may be sourced from Manufacturers 

websites, Consultants or be images from scaned details. 

We can use the same method as described previously, but instead of dragging a detail 

from an existing ArchiCAD .pln file, we can paste information in PDF, DWG, DXG, DGN, 

JPEG and many more. 

 Open Section AA again 

 Open the Detail Tool and setup to create an new detail viewpoint 

 

 

 

 Make sure it is set to Create new detail viewpoint and set the Marker to 

reference to The first placed drawing of the viewpoint. 

 Create the detail around the Window Sill on the left wall of Section AA. 
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 Select the Detail Marker and right click and choose ‘Open Detail Drawing’. 

This is a quicker way to get to a source view without having to go to Project Map. 

 

 

 Set the scale of the page to the same scale as the PDF (if you are unsure set the 

scale to 1:1) For the purposes of this training, set the scale to 1:2 & 100% 

 

 

 Select the Drawing Tool from the ToolBox (no need to open the Tool, just select 

it) 

 

 

 

 Click somewhere to the right of the Source Detail. 

 In the new dialog, Browse for your file to insert.  Choose the BIM Intro folder on 

your desktop, and click on the file Fletcher Detail.pdf 

 

 

 A common problem with PDF’s is that you cannot modify them, so if we wanted 

to to adjust something about this Detail we would have to redraw it. ARCHICAD 

can now explode Vectorial PDF’s to extract their lines. First offset the edges to 

remove the header and footer as they are unnecessary: 
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 Once trimmed; right click the Drawing and go to ‘Explode into Current View’ 

 

 You can control how it appears from the Layers, Lines & Pen it uses, we are 

going to untick ‘Keep original elements after exploding’ to remove the PDF: 

 

 Click OK and the Detail will now be a collection of Lines & Text you can modify. 

 

 Zoom in so the exploded detail is all you see, and save this as a View. 

 Goto the View Map in the Navigator 

 

 

 Choose the Save Current View button 

 

 

 

 

 The General View Settings should be fine – as we are looking for a “What you 

see is What you get” type view. 

 

 Make sure you set the Zooming to Current Zoom 

 Hit Create 

You have now made a detail in ArchiCAD that ‘links’ to a detail that you have not 

created. We can place this on the same Layout as our previous Detail. 

 Open the Layout Book in the Navigator 

 Double click on your Detail Layout to open it. 



    INTRODUCTION TO BIM 

Page 126 of 166                Introduction to BIM    

 Switch back to the View Map view and highlight your new Window Head detail 

and drag it onto your Layout. 

 

 

Back in your Section View, your Details Makrers will have updated themselves. 

 

 

Module 14 – Drawings and 
Layouts 
In Module 3 you created a series of Layouts for the Bach. In this Module we explore drawing 
and layouts further, introducing the following: 

 Master Layouts 

 Auto Text 

 Drawings 

 Titles 

 Publishing 

 

BIM Note: 

At this point in BIM we are simply using the powerful publishing features of 

ArchiCAD to organize our model views ready for issuing to various 

consultants and the client. There is no more actual modelling needed. 

Master Layouts 

 Switch the Navigator to the Layout Book 

 At the bottom you will notice a series of 

Master Layouts 

 Double Click the A1 Landscape Master 

 Click the Settings button 
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 Explore how the page has been defined 

 Click Cancel (you don’t want to keep any changes you inadvertently made!) 

 You can create new Master Layouts by using the Right Click menu and selecting 

New Master Layout… - this allows you to create pages of different sizes or 

pages of the same size with different styled title blocks for different uses. 

 Also notice that the A1 Landscape page icon has the page corner folder over 

 

 

 This indicates this Master Layout is the Default– all new layouts created will use 

this Master by default but can be easily changed in the settings. 

 If you want to change which Master Layout is used by Default, Right Click on 

the Master you want to use and select Set as Default from the menu 

 Change the Default to A3 Landscape 

 Change the Default back to A2 Landscape 

Auto-Text 

 Zoom in on the Title Block at the bottom right of the page 

You will see some standard text along with some text blocks starting with #’s – 

the # indicates Autotext 

 

BIM Note: 

Autotext need only be edited once, then everywhere the Autotext is placed it 

will automatically update.  Your Office template (ArchiCAD BIM Start point) 

will have Autotext peppered around Views and Layouts ready to be 

automatically filled in when the relevant info is added. 
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Project Specific Autotext 

 Some Autotext is Project Specific for example #ProjectName and #Client 

 You can see the Autotext we added on Day 1 

 Open the File > Info > Project Info… dialog 

 This is where we update project related information 

 Update Site Address & Site City fields 

 Click OK – you will notice the Autotext is replaced with your new values 

 

Layout and Drawing Specific Autotext 

 Some Autotext is not controlled by adding into the Project Info tab. 

 In the bottom of the title block you will notice there still remains some Autotext for 

example, #Layout Name and #LayID 

 

 

 This Autotext is layout specific so you need to be on an Layout for it to display 

the correct data 

 Double click on a few of your Layouts and see how the data changes for each 

Layout 

 

 Drawing or Revision Specific Autotext is data 

related to an individual Drawing or Revision 

status. For example a Drawing Title – we’ll look 

at this in the next Sectio 
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Drawings 

 Double-click on your Ground Floor Layout and make sure you can see the full 

Layout by using the Fit in Window button at the bottom of your workspace 

 You will see the Ground Floor Plan 

 Below the Plan you will see a Drawing Title 

 

 

 The Title currently displays the Drawing Number (useful when there are multiple 

Drawings on a page) the Drawing Name and the Drawing Scale (this is all 

Drawing specific Autotext) 

 Select the Drawing and open the Drawing Selection Settings (Ctrl-T for PC 

Command+T for Mac) 

 Browse through the various Settings 

 

 

 In the Title Tab change the Built-in Drawing Title to No Title 

 Click OK 

 You will notice the Drawing now has no Title 
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Back Referencing 

This is a useful feature of the Titles when used. For a Details sheet you may want to 

show which sheet the Details have been derived from much like seeing what sheet the 

Detail is on in the Section Layout. 

To do this within the Title settings choose Back Reference and enable it. Since there is 

only one Reference at the minute with these details we can tick ‘Enable all References’ 

 

Cropping Drawings 

In some instances you may want to crop a Drawing so you can only see a portion (for 

example if you were doing a Kitchen Plan) 

The Frame / Boundary of the Drawing works in the same manner as other polygons like 

Roofs and Slabs 

 Select the Drawing 

 Use the Pet Palette to reduce the edges of 

the Drawing so you can only see the 

Kitchen 

 

 

 Click within the Drawing Frame and use the 

Pet Palette to move the contents of the 

Drawing 

 Click Undo as many times as required to 

get back to the full Floor Plan 

Moving Drawings from Layout to Layout 

Using the Navigator you can drag Drawings from one Layout to another. 

 You will notice that each Layout in the Navigator has a Plus symbol beside them 

 

 

 Click the Plus Symbol to Expand the information 

 You will see the Name of each Drawing placed on the Layout 

 Expand the 04 Elevation Layouts 

 

 

 

 Pick up the East Elevation Drawing and Drag it onto the North Elevation 

Layout 
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 Pick up the West Elevation Drawing and Drag it onto the South Elevation Layout 

 

 

 As the East Elevation Layout and West Elevation Layout now have no Drawings 

you can select and delete them 

 Double Click on the North Elevation Layout & change the Name to Elevations 

 

 Select the Elevations and Drag them so they can both be seen (drag one up the 

Layout and one down the Layout) 

 Repeat the exercise for the South Elevation Layout 

 You may need to right click the drawing and choose ‘Update’ 

Creating a Subset style Layout Book (recommended) 

Setting your output documentation to use a Subset style numbering system means you 

can easily add new documents to your set without re-numbering the remaining sheets.  

This becomes invaluable if the sheets have already been issued. 

 

A Standard system to achieve may consist of: 100 series for Plans, 200 series for 

Sections, 300 series for Elevations, 400 series for Details etc.  

 

NOTE: This is the default in the ArchiCAD 19 Template.tpl that shipped with the 

ArchiCAD 19 DVD. 

 

 Go to the Navigator > Layout Book,  

 Select the Top folder in the tree, right-click and select Book Settings...  

 Select Use Hierarchy (Tree View by Subset) and choose your ID Style 

 Click OK. 
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 Create your first Folder; we will first create a folder for Plans.  

 Set to Assign ID Automatically and to Use Prefix & ID of Upper Levels.  

 Then set it to Use the ID of pper level but uncheck Add Prefix for this Subset 

 Then set the ID style to 01, 02, 03… and you can see the preview to the side. 

 

 Drag the Ground Floor Plan and drag it into the newly created folder. Note that 

it has now had its page number reassigned in accordance with the folder it is 

located in. Right-click, choose Layout Settings...  in this dialog you will see why 

this is: ID to Use Automatic Book and Subset ID assignment.  

 

 

 

 

Note that the Sheet Index in our example has no number. This is because within the 

Layout Settings under ID we have ticked Do not include this Layout in ID sequence. 
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Publishing 

Publishing is the fourth section of the Navigator. Publishing handles all output from the 

BIM model. Output could be to a printer or plotter, to PDF files and can even be used to 

export DXF/DWG 2D files or IFC 3D files to send to consultants 

 

 Switch to the Publisher Mode in the Navigator 

 

 

The Template file has been set up with several Publishing sets that publishes all the 

Layouts to different formats. 

We are going to choose the Publisher set ‘All Layouts to 1 PDF’ which will export all the 

Layouts to one merged PDF file with multiple pages. 

 Select the Layout Book at the Top of the List 

 Ensure the Merge to one PDF file is Selected  

 Click Publish 

 

 You will be prompted to give the PDF a name – save it to the desktop 

 A dialog pops up to show the Publishing progress 

 

Here you can see the progress of the publishing & the file size of each page. 
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Now navigate to your desktop to the AC19 BIM Intro folder and you should have your 

entire project saved as a PDF. Double click it to open and all your Layouts will be 

organized one after another in a single PDF file. 

 

The published PDF will automatically include the Layers used to create the Layouts. In 

Adobe Acrobat reader click the Layers button at the left to reveal them: 

 

Here you can turn off Layers on the fly to show/hide information. 

Extension 

 If you have time Create a New Publisher set  

 Use the up arrow to see all Publisher Sets: 

 Then choose the ‘Create new Publisher Set’ icon from the bottom: 

 Here you can name the Publisher set as relevant 

 Create a source folder – this will help set the format. 

 Add the Layouts using the Organiser 

 And set the output format to DWG 

 

 

 

 

 

 

 

 

 

 

 

 



INTRODUCTION TO BIM   

Introduction to BIM   Page 135 of 166 

Module 15 – Sun and Shadow 
This module looks at creating Shadow Diagrams and Sun Studies. 

Sun Study 

Often as a design tool it is good to create a study of a particular space to illustrate the 

sun’s path over a day.  

 Navigate to your Ground Floor Plan 

 Double Click on the Camera Tool in the Toolbox to place a Camera in the 

Kitchen/Entry looking to the top-right 

 

 

 

 Select the placed Camera and open its Settings. 

 Change the Camera and Target heights (so that the camera is not in the ground) 

FFL + 1700 eye height (145100 + 1700 = 146800) and widen the View Cone. 

 In the Camera Settings dialog you can also edit the Sun settings and check your 

Date, Time and Location from the Sun... tab 

 Then select Project Location... to edit the location 

 

 

 Hit Cities and select your City 

 Project Name should come through from your Project Info. 

 Hit OK 
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 Open your Camera View from the Project Map 

 Go to Document > Creative Imaging > Create Sun Study..., choose to show in 

the 3D window 

 

  

 

Within this settings window you are able to set the Date and the duration of the Sun 

Study and the interval. (time between frames) 

As per all renders you can choose a Result: (format) Typically this will be QuickTime 

Movie; or a series of still images (JPEG images) 

 

 Hit Show to check you Sun Study 

 Make changes if necessary – Hit Save...  (which saves a Quicktime Movie) 

 Save this to the folder on your desktop. 

 On Mac double click on this file to view your building from Sunrise to Sunset. 

 On PC right click and choose, Open With > QuickTime Player 

 

NOTE: As this has created a QuickTime (.mov) file, you will need QuickTime 

installed to view.  QUICKTime is installed as part of the Mac OS, for PC users it 

is installed with ArchiCAD.  If you are sending a file to your customer, they may 

have to download Quicktime. 

Shadows in Elevation 

Sun Studies can also be used to illustrate Façade Sun Studies. These can be simply 

created in your Elevation Views.  

 Open the Elevation Settings – right click on the Elevation and select Elevation 

Settings... 

 Within Model Display > Uncut Elements note that Fill Uncut Surfaces with: is 

set to Own Material Colors (Shaded) this is adding colour to the elements 

 Within Sun and Shadows the Sun Shadows is ticked, this is turning ON the 

shadows. 

 Viewpoint Sun Settings defaults to custom, which has the sun coming from 45°, 

45°, change this to As In 3D Window to get the sun as set up in the 3D window 

 

 

 

 To set the exact Sun shadows for a specific time of the day, go to View > 3D 

View options > 3D Projection Settings and hit More Sun... 
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Shadows in Plan 

Illustrating the shadow footprint of a building is often critical to show proposed 

developments and their effects on neighbouring properties.  

 

 View your model in 3D using Parallel Projection Settings-Top View.  

 Right click in your 3D view, select 3D Projection Settings... 

 Choose Top View from the flyout on the right 

 Orientate your view – generally set the X, Y & Z to multiples of 90 

 

 

 

 Within More Sun... Set the location of your project, the Date and Time of day. 

 

 

 

 Hit OK, to view the shadows 

 

 

 

 You can also use the 3D Document Tool to save views with Shadows Contours 

turned on, then add dimensions and text if needed. 

 Simply Right Click in white space of your 3D View and choose New 3D 

Document from from 3D… 
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 Give the View a name: Plan Shadows 

 

 Right click in white space of this new view and hit 3D Document Settings... 

 

 Within SUN AND SHADOWS > Sun Shadow, choose On with Contours 

 

 

 Use the Text tool, and Dimension tool to add additional information. 

 

 You can then save this as a View to issue in your documentation. 

 

3D Documents are really useful for a variety 

of uses including: 

 Sun Study 

 Shadow Analysis 

 3D Details 

 Axonometric setouts 
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Module 16 – Rendering 
Rendering just got a lot easier & better with ArchiCAD 18, its scalability means that you do 
not need to adjust complex settings to produce a high quality render. However fine-tuning a 
render to get top quality renderings takes time, patience and experimentation. 

In this module you will learn a few basics and then get on with some experimenting! 

We explore both the Sketch Rendering Engine and the new CineRender Rendering Engine. 

 

Sketch Engine 

 Bring up the NE 3D View you saved earlier in the course. 

 Open the Document > Creative Imaging > PhotoRendering Settings palette 

 Set the following: 

 Click the Camera icon at the bottom to Render. 

 Rendering can take a while because it a complex process - shortly you should 

see an image 

 

PhotoRendered Images can be Saved in a variety of industry standard image formats 

(for example tiff, jpeg, etc) simply hit File > Save as... 

You can even place renderings onto you Layouts by saving a View. 

 Give it a try – in the 3D view click Save Current View icon in the View Map: 

 Then in the 3D window settings of the View set it to your desired Render Scene: 

 

 Experiment with different 3D View points and different Sun Settings 

 Try different rendering styles by adjusting the Basic Settings within the 

PhotoRendering Settings. 

 For even more control explore: Enhancements, Sketch Line Settings, Hatch Line 

Settings and Shadow Line Settings. 
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CineRender Rendering Engine 

The CineRender engine was introduced in ArchiCAD 18 based off the technology found 

inside Cinema 4D and is used to produce more photo-realistic renderings of the model. 

Let’s just see what the default Render looks like first before we get into setting it up. 

You should still have the Photorendering Settings palette open. Change the scene to: 

You can get a quick preview of the Render by hitting the Refresh icon in the Preview 

window of the Photorendering Settings palette: 

As soon as you’re happy with the result click the Camera Icon to get a full Render: 

This will take a minute or two to render. It renders from the centre of the image to give 

you an idea as soon as possible of the quality of the render. If it is not turning out well 

you can just click the Stop icon at the bottom to adjust the settings and try again: 

 

These pre-installed Scenes help you create a large variety of appearances of your model 

without ever having to adjust a settings. Click the drop-down menu at Scene and choose: 

Choose another scene from the Outdoor folder and render this to see the different options 

available without ever having to change a setting: 
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 OK lets get into the settings now to show how its set up. First the size of the render. Click 

the Dimension tab at the top of the Photorendering Palette: 

So this is the size it is rendering. Pixel size varies between computers depending on the 

screens resolution so this can be difficult to calculate. If you click where it says ‘pixels’ and 

change this to ‘mm’ you can set the physical size of the image: 

Now when you set the size of the image you can now set its Resolution, this is the amount 

of pixels in the size you’ve determined. It will be 72 DPI by default as this is the resolution of 

most computer screens and is good to get an idea of how the Render will look. 

150 DPI is really as high as you want to go for high quality presentation renders as this is the 

best a normal printer can print and the computer screen will now show all of the detail. By 

increasing the DPI the time taken to render is increased accordingly so best kept low. 

With the new settings you will get a high quality Render for presentation purposes. 

To help with this there is a range of default sizes available up top you can easily choose: 

 

The Apply Render Safe Frame option ensures that what you see on the screen is exactly 

what is rendered by greying out any part that will not fit in the ratio of your render: 

If this is turned off it will render outside your screen to fill the extra space of your ratio. 
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Now that weve got our size of the Render correct lets look into the actual Render settings. 

Go back to the Settings tab Expand the Render Settings: 

These settings will be defined by the Scene you chose at the top of the Settings, as soon as 

you change these it will change to a Custom scene. 

Here you can control: 

 Rendering Quality  

 Shadow Quality 

 Light & Sun intensity 

 Effects 

 Depth of field 

Now within the Environment section of the palette can define the Sky & weather in your 

render and the position of the sun: 

You can choose from a large range of Physical or HDRI skies: 

Physical Sky = models a sky to provide accurate lighting in accordance with weather 

HDRI Sky = provides a HDR 360 image to provide background & lighting. 

 

You can also change the Sun’s position to give you a render at an exact time of day. It 

will list the time we set previously when creating a Sun Study, but you can set this to be 

independent as we will likely do a Sun Study in winter & a Render in summer.  

If you choose to have No Sky you can import your own image of the context of your site 

under the Background tab of the Photorendering Settings Palette. 
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ArchiCAD 19 comes with a range of Lamps which are optimized for the CineRender 

engine, this will help provide more accurate lighting conditions which can be controlled. 

Open the Lamp Tool for the More Toolbox and choose Sun Object 19: 

 

As you can see you can control the colour of the sun to set its warmth and the shadows it 

creates. Let’s create a sunset which will have a warm colour but low intensity: 

 
Place it off to the side of your project. ArchiCAD will put the sun in the correct position in 3D: 

Now back in the Photorendering Settings palette let’s turn the ArchiCAD Sun down and turn 
the Lamp tool up which will give us more accurate lighting effects. 

 
 
We will then change the Sky to be something more appropriate, lets try a HDRI sky now 

which encompasses the light quality and intensity as part of the sky image as well: 

 
Ive chose ‘Sunset Cloudy GS.hrd from ArchiCAD Library 19>HighRes Luminance 19 

 
Once you’ve set this click the Camera icon at the bottom of the PhotoRendering palette. 
Now you can tweak the settings to get the effect you are looking. 
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Lastly we will look into the Surface settings of the surfaces used in our render. This is all the 
surfaces we see when rendering. A new feature of ARCHICAD 19 will be extremely helpful 
for this, open the Surface Painter palette in Window>Palettes>Surface Painter: 

 
Here we can see all our Surfaces in our project & catalogues. We are going to replace the 
Surface used on the Northern Pergola with a different decking Surface.  
At the top of the Surface Painter palette search for Wood: 

 
The folder icons show Surfaces that are part of the additional Surface Catalogues provided 
with ARCHICAD 19, If you select one you will need to click ‘Add to Project’ to add this 
Surface to your project to be able to use: 

 
 
Now click the click to activate it and if you move your mouse onto your model you will be 
able to paint the surface of any element. Click the top of the decking: 

 
 
We will want to change the side surfaces as well so rather than click every face if you hover 
over the side and hit TAB it will now paint all Surfaces of the decking with this Wood: 

 
 
Also change the two steps using the same method. 

 
 
We can also easily access its Surface settings by double clicking the Surface within the 
Surface Painter palette. 
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Each Surface has its appearance set in the normal 3D window using OpenGL settings. 
However we are more concerned about their appearance when rendering so change the 
Engine Settings to CineRender by MAXON 

 
Here you can see all of the different settings that define the appearance of each surface: 

 
These are quite complex and go beyond the time we have in training. If you want to read 
more about each of the settings and what they control you can read more here: 
 
http://helpcenter.graphisoft.com/guides/archicad-19-int-reference-guide/user-interface-
reference/dialog-boxes/surface-settings-cinerender/ 
This is largely unnecessary now as ArchiCAD now comes with a large Surface catalog on 
top of the 140 Surfaces you currently see. You can add these additional Surfaces to your 

project to use or replace Surfaces you are currently using with ones from the catalog. 
 

We are going to replace the Surface settings of our foundation to look more realistic. Choose 
Concrete 02 then click ‘New’ and ‘Replace from catalog’ 

 
You can then just search for any surface you want and choose the most appropriate one. 
With over 800 Surfaces available we have everything we need right out of the box! 
 
Once you’ve done that click OK and the Surface appearance of your foundations should 
update. Simply click the Camera icon at the bottom of the PhotoRendering palette now: 

 
 
 
 
 
 

http://helpcenter.graphisoft.com/guides/archicad-19-int-reference-guide/user-interface-reference/dialog-boxes/surface-settings-cinerender/
http://helpcenter.graphisoft.com/guides/archicad-19-int-reference-guide/user-interface-reference/dialog-boxes/surface-settings-cinerender/
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BIMx 
Renders have traditionally been used to convey architectural designs in an more visual 

method than plans which can appeal to clients. However they can not interact with the 

model to see other parts. 

BIMx has been a feature of ArchiCAD for several years, but for Version 17 it was 

included as part of the install for free! This is an extremely powerful tool at all stages of 

the project from helping with the sales process to the build on site.  

 

Saving a BIMx file 

To save a BIMx file it is as simple as File > Save as while in the 3d window and choose 

BIMx from the list of format types: 

 

 

 

The checkbox for ‘Start BIMx after save’ will auto-launch the program so you can 

preview the BIMx model before sending it out to your client. 

 

The BIMx application 

BIMx is installed automatically with every ArchiCAD installation and you will find its icon 

on your desktop. It will automatically launch once you save your file & open were you 

were looking at the model from the point you saved it: 

 

 

 
The model will behave much like Fly-Through mode in ArchiCAD. The mouse is where you 

look and the arrow keys is where you move, much like a computer game. So to walk forward 
you look forward with the mouse & press the UP key. 

 

Useful Shortkeys 

I  = info, you can find out the name, size & layer of any component on the model 
O  = outlines, this draws a thin black line around all edges for better clarity 
M  = measure, you can measure the distance between any 2 surfaces 
F  = fly, this works exactly like fly-through mode where you can fly through walls 
SPACE  = jump, you may need to jump onto the Pergola, you can walk up steps 
ESC  = menu, this will allow up to upload, shade & see the rest of the shortcuts 

 

Sending it to the client 

You can either use this as the medium to discuss the proposed building in a meeting 
keeping you in control or send them to the file, the file you just saved is around only 1MB 
making it easy to email. Alternatively you can create an account with Graphisoft to upload 
the file to cloud storage & able to send your client a link to download it from. 
 
It can then be viewed on a PC, Mac, Ipad, Iphone, Android phone by anyone. 
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There is also a ‘Hyper-Model’ function to BIMx. This not only exports the 3D model as a 

BIMx file but also all of the Layouts associated with it so you have a full set of working 

drawings which can all be accessed via the 3D model or the same folders you created in 

your Layout Book. 

 

   BIMx Publisher Set 

This is all done with the Publisher and to make life as easy as possible we have created 

a Publisher Set to do just this in the standard NZE template. Navigate to the Publisher 

and at the top where it says ‘All Layouts to 1 PDF’ change this to ‘BIMx Hyper Model’: 

 

As you can see there is 1 3D view and the entire contents Layout Book including the 

subset folders so they are neatly organised when opening the BIMx file on another 

device: 

The 3D view Generic Perspective is the 3D model that will get exported and how the 

model will appear when first opened, so it’s best to have this View set correctly to give 

the client the best possible first impression when opening up and seeing their design.  

The rest is just a duplicate of the Layout Book, but you can add particular Layouts if you 

want rather than the whole Layout Book.  

BIMx Hyper Model functionality is available on portable devices currently so you can 

view it on any smartphone like iPhone or Samsung but it looks a lot more impressive on 

an iPad or Android tablet. 

If you save a BIMx Hyper Model on your computer you will still be able to view the 3D 

model but will not be able to access the Layouts.  

When the BIMx model is downloaded and viewed on a Tablet device they will be shown 

the exact same format that you had set up in your Publisher Set:  
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Around your 3D model will be a series of Blue Markers, these are where your Views 

have been generated from and what is on your Layouts and would do exactly what you 

expect. The Markers you will expect to find around your 3D model are the Plans, 

Sections and Elevations. So for example if we click the Blue Icon that appears to slice 

our building you will get a small preview of the Layout that is linked to that Marker: 

 

If you choose ‘Show in 3D’ it will show a ghost of the Layout in the 3D model: 

 

 

But if you click Open you will get a smooth transition as the model spins to an 

appropriate angle and peels back to reveal the Section & the Layout: 

 

It then zooms in so you are only left with the Layout:  
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Appendix 
This additional information is provided to show some alternative methods of creating 

ArchiCAD BIM data. 

Site Modelling . . . . . pg 145 

Details direct onto Layouts (Linked Markers) . . pg 151 

Renovation Tool . . . . . pg 154 

Layer Appendix . . . . . pg 156 

Pen Table . . . . . pg 158 

Mac Shortcut Keys . . . . pg 161 

PC Shortcut Keys . . . . . pg 163 

 

Site Modelling 
In this section we detail the second method of creating a Terrain Mesh in ArchiCAD. 

Modelling from a Surveyor’s DXF/DWG.  

 

In the course we cover the method for Certificate of Title as it is a common workflow & 

suits for the time constraints of this course, however quite often you will find that you will 

need to engage a Surveyor and will subsequently receive a DWG from them with all the 

information on it. In this section we show how you can use this method. There are also 

several useful YouTube videos on this top you could watch also. 

 

Importing survey information 

You can import DXF/DWG info in three ways: 

 

Merge 

Use Merge if you want the incoming content to be fully editable.  File> File Special> 

Merge…  

This will bring in all the layers, line types, line styles, fills etc associated with the DWG 

and add them into your project. All lines are individually editable. If at some stage you 

finish with the DWG content and wish to remove it you can only delete it, but all the 

attributes remain. 

This method can be great for details and such, and usually the Merge happens into a 

special detail template, and the purpose of the merge is to strip out all the DWG layers 

and clean up the detail so that it only has the ArchiCAD Attributes we want (Layers, line 

types, fonts etc) 

 

Place External Drawing 

Use Place External Drawing if you do NOT want to change the content at all.  File> 

External Content> Place External Drawing… All you can do with this information is 

move and scale as one entity. When using this method the Default Settings of the 

Drawing Tool are used to place the DWG. 

 

Attach Xref 

Use Attach Xref if you only want to be able to turn layers on and off.  File> External 

Content> Attach Xref… 

 

Bringing the content in as an Xref means that when you Detach the Xref all the attributes 

(line types, line style, layers etc) associated with that Xref will be removed along with it. 

Attaching as an Xref also stores the Xref Layers in a separate part of the Layers list, and 

these layers can be hidden. 

Xref content cannot be scaled or rotated once in the project, so you must set your scale 

and rotation through the Attach Xref dialog.  

 

For this Workflow we will Attach the file as an Xref. Having the surveyor’s file as an Xref 

groups the layers prefixed with the name of file in the Layer List, and cleans up all 

attributes associated with the Xref when it is removed. 

As the surveyor’s drawing is an external document we are going to store it in an 

Independent Worksheet.  
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 Right Click on the Worksheet tree in the Project Map and choose New 

Independent Worksheet.  

 Give it an appropriate Name and ID and click Create.  

 

 

 

 Select File> External Content> Attach Xref  

 Browse for the Surveyor’s file then click Open.  

 When selecting a scale factor we need to know what scale the surveyor has 

used, typically this is 1:1 but as surveyors use meters rather than millimeters, we 

set the x & y scales to 1000.  

 Place on Story 0 (Sea Level/Datum) 

 Set Translator to For editable import 

 

 

Use the Fit in Window to locate the survey; it maybe a long way from your project origin. 

 Double-click on your mouse wheel 

 Or hit the Fit in Window button at 

the bottom left of your workspace. 

Once you have successfully imported your 

survey plan, you may find (as shown here) that there is extensive detail, text and lines 

making the plan very hard to work with. 
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To make things easier we suggest you open up the Layer Manager (Ctrl+L PC or 

Command+L Mac) and turn off any layers 

which are not needed for creating our mesh. 

The Xref layers will be grouped at the bottom 

of the layer list with the Xref file name as the 

Prefix.  

NOTE: If you are not sure of what ifno is on which layers, DO NOT turn any off. 

 

Now Save a View of the Survey drawing so you don’t have to remember this layer 

combination.  You need to use a Custom layer combination as none of the Surveyor’s 

Layers will appear in any of your pre-set Layer Combinations. 

 

 Switch to the View Map in the Navigator 

 Hit the Save current View Button 

 The default Settings should be fine 

 Click Create. 

 

 

 

Creating you Mesh 

Before you make the mesh, have a close look at your imported DXF/DWG and find the 

lowest level given on your site.  

 

 

This particular plan has been measured relative to ‘Sea Level’ and has a lowest point of 

‘90.7m above sea level.’ Now we can set our Mesh start level based on this Low Point. 

 Open up the Mesh Tool from the ToolBox 

 Under Geometry and Positioning input your lowest site level. (Our lowest level 

is 90.7m so it is recommended you use the nearest round meter below your 

lowest level. In this case it would be 90m or 90000 mm).  

 Enter 90000 to Story 0 

 Click OK 
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This will elevate your mesh to or slightly below the lowest point of your site when you first 

model the shape. This is the first step to not creating a Skyscrapper mesh. 

 Navigate to your Sea Level/Datum Story in your Project Map. 

 Change to your View Map and right click on your new saved Survey and choose 

Show as Trace Reference 

 Set the Mesh Geometry Method to Polygonal 

 

 Trace around the perimeter boundary of the site or, alternatively, you can Magic 

Wand the perimeter line of your site if the Surveyor has drawn the boundaries 

intersecting at the corners.  

Adding Contours 

Once you have completed your shape you need to create your Mesh Contours.   

NOTE: At this point you need to make sure the Contour lines drawn by your Surveyor 

are continuous across the site.  I.e. they cannot be broken to display the contour height, 

also the need to cross the edge of the site.  

 

If the Contours are broken by text, of they do not extend to the edge of the Site you will 

need to retrace them with the Spline Tool (or request from the Surveyor that it is redone) 

 Making sure that you are on the Mesh Tool  

 Select the Mesh 

 Use the Magic Wand (Space Bar) to trace over the Contours (or your new 

Splines) one-by-one.  

 A dialog box will pop for each contour. Always choose No Surface Fitting. 

 

TIP – It may be clearer to hide the Xref layers before Magic Wanding the splines. 

 

 

If you need to create Spot heights: with your Mesh selected, and the Mesh Tool selected 

in the Toolbox, set the mesh Geometry method to Polygonal and double click on the 

Spot location.  As before, choose No Surface Fitting and click OK. 

A new Spot will appear on the flat Mesh. 

The next step is to give your mesh height by selecting a contour, spot height or corner 

node 

 With the Mesh Selected and the Mesh Tool highlighted 

 Click on a black height spot (this could be an individual spot, a spot that is part of 

a complete contour line or a corner spot) and choose Elevate Mesh Point from 

the Pet Palette.  
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 At this point it would be a good idea to turn back on the layers containing the spot 

and contour level labels from your surveyor’s plan. 

 

 

 

 

 

 

 

 

 

 In the Mesh Point Height dialog set the height to measure from to Project Zero 

rather than the default Mesh Reference Plane  

 Input your survey level e.g. 90000, 91000 etc, and be sure to tick Apply to All if 

you are editing a complete Contour line. 

Important: You must ensure you are measuring relative to Project Zero because this is 

our datum and it allows us to put in the true survey levels. If you measure from ‘mesh 

reference plane’ the levels you put in will measure from the top surface of the mesh and 

you will end up with a ‘Skyscraper mesh’ as mentioned in page 66. 

You may find in some instances end nodes that sit on the intersection point of a contour 

line and the boundary of a mesh may sometimes require individual heights allocated to 

them too. It is a good idea at this point to view your mesh in your 3D window to 

determine which mesh points are still sitting at zero and need to be edited. 

 

 

Once all mesh points and contours have been given heights you will now be left with 

your three dimensional site mesh. 

 

 

Setting up Stories 

Now that your mesh is complete you can decide on the finished floor level of your 

building and set up your stories to match. From ArchiCAD’s Design menu you can open 

up Story Settings. 
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Up until now we have been modelling our site and it has been on ‘Zero Story’ ArchiCAD’s 

‘Project Zero.’ Because this story has been used as our datum it should be named 

appropriately, in this case ‘Sea Level.’ Do not use this story for your Ground Floor as it 

will not be relative to your mesh. Put your desired Finished Floor Level height in the 

‘Height to Next’ field of your ‘Zero Story’ and ‘Insert Above’ your Ground Floor. In this 

case we have set our finished floor level to be 92500 (92.5m) above sea level. By setting 

our finished floor level relative to sea level we are giving an accurate height 

corresponding to our surveyor’s data. 

 

Under most of the modelling tools you will now find you 

can set a height relative to the story you’re on or to your 

‘Project Zero’/‘Sea Level.’  

 

Relative Spot and Elevation Levels 

 

Now that you have a mesh modelled relative to your Surveyor’s data you can now 

generate your own spot levels that may be currently 

unknown.  

 Select the Level Dimension Tool           from the 

ToolBox 

 and from ArchiCAD’s Gravity pulldown choose to 

Gravitate to Mesh. 

 Now all you have to do is click on your mesh at 

the desired spot level locations and you will get ‘relative’ spot levels. 

 

You can also place Elevation levels using the Dimension tool         .  

 

 Go to a Section or Elevation window.  

 Open up the Dimension Tool from the ToolBox.  

 Set the Dimension type to Elevation Dimension.  

 This will change the interface allowing you to set the Dimension Origin. Make 

sure it is set to Project Zero (Sea Level)  

 

 

 Place the dimensions the same as you would with a standard dimension. Click 

on any point to dimension and then double click to finish.  Now click the 

placement hammer to place the dimension label. 
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Details direct onto Layouts (Linked Markers) 

Another way of getting Manufacturers or Consultants information into ArchiCAD is to 

place it directly onto the Layout.  This process requires the use of Linked Markers 

(instead of Source Markers – which it what we have used in the main training booklet) 

 

NOTE: Backreferencing will not work to Linked Markers, so for the most part the 

previous methods of adding details are preferred. 

If you don’t want to Backreference your detail information then you can use the following 

process. 

 

 Open the Layout that you wish to place the detail. 

 Click on the Drawing Tool from the ToolBox. 

 

 

 

 

 Click on the Layout and you will be prompted with a File Dialog, select to link to 

an external source, and select browse. 

 

 

 

 Browse for your desired PDF  

 The PDF detail will now appear on the Layout. 

 

 

 

 Rename the PDF to something appropriate (Window Head). 

 Edit the Title to not show the Scale 

 

  

 Now we need to place a Linked Marker to the pdf detail. 

 Use the View Map to open up your Section. 
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 Select the Detail tool. 

 The Detail Marker Settings need to be set the Place a linked Marker, with the 

Marker referencing to a selected drawing. 

 

 

 

 The dialog will prompt you to select the Drawing  

 

 

 

 Place the Detail Marker around the window head it will automatically link to the 

drawing on your Layout. 
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Renovation Tool 

The Renovation Status was introduced to ArchiCAD in V15 to allow for efficient 

management of addition and alteration projects. Renovation Status is element based so 

no additional layers or layer combinations are required beyond the standard set of layers 

for a new project. There are three different Renovation Statuses; Existing, Demolished 

and New. Renovation Filters show, hide, or override the display of elements enabling the 

efficient production of documentation and communication of the project. 

 

Renovation Status 

The Renovation Status is by default set to Existing. The 

Renovation palette allows the default Renovation Status to 

be changed. Grey Brick for Existing, Bulldozer for To Be 

Demolished, and Red Crane for New 

 

The third button overrides the typical display of elements 

this will from All Relevant Filters to Pin the Element so it 

only displays in the currently selected renovation filter. This 

is best used for annotation that is specific to the View that 

the Filter is used for eg demolition plan notes. 

 

Both the Renovation Status and Show On Renovation 

Filter can be set in the individual element settings under  

Tags and Categories previously within Listing and Labelling. 

Setting & Assigning Renovation status 

To get started with Renovation you just draw the existing conditions & then make the 

modifications involved in the project. From there you can assign each of those a status 

which allows ArchiCAD to automatically produce the documentation based on filters.  

 

Ie: if we were to start demolishing items from existing house 

1. Open the Renovation Palette Window > Palettes > Renovation 

 

2. Set the Renovation Filter to 02 Demolition Plan  

 

2. Select the elements that you want to demolish to allow for the 

new building and click the to be To be Demolished Status button (the Bulldozer!). 

 

Any text or labels that you only want to appear in a certain view you can do this by 

opening their Selection Settings. In the Tags and Categories settings set their 

Renovation Status to To Be Demolished and Show On Renovation Filter to 02 

Demolition Plan 
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Renovation Filters 

 

The renovation filters are defined in the menu Document > Set Renovation Filter > 

Renovation Filter Options. Renovation Filters are similar to Model View Options. 

 

 

The Renovation Filters control the display of Elements based on the three Renovation 

Statuses; Existing, Elements to be Demolished, and New Elements.  

For each of the 3 Renovation Statuses, there are 3 visibility options Show, Hide and 

Override. 

 

For the NZE ArchiCAD 17 Template we have provided 8 Renovation Filters  

 

00 NOT IN USE New projects, all elements displayed no filters applied 

01 Existing Existing Plan, all existing elements displayed including 

those to be demolished, no filters applied 

02 Demolition Plan Demolition Plan, displays Existing, and demolished 

elements with filter applied 

03 After 

Demolition 

 

Shows only existing to remain, used to communicate the 

demolition process 

04 All Works Shows all works with New and Demolished, used to 

communicate the renovation process by identifying 

Existing, Demolished and New  

05 New 

Construction 

Shows Existing and New with filter applied to New 

Elements used to communicate new construction 

06 Proposed Plan Proposed Plan, New elements use standard pens, Existing 

display with override filter. 

07 Finished New and remaining Existing elements displayed, used to 

for visualization / communication of the proposed finished 

design. 

 

Renovation Override Styles 

 

The Renovation Override Styles allow the default display options (Pens, Lines, Fills etc) 

to be overridden to better communicate the renovation project. These are both a 

visualization tool and a documentation tool allowing change to be highlighted. 

 

Each of the Renovation Statuses has a Renovation Override Style, the predominant 

theme is grey for Existing, Yellow for Demolished and Red for New. 
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Saving Views with Renovation Status 

The Renovation Status is defined in the View settings of each View, the Quick Options 

Palette also allows for these to be toggled between.  

 

 

 

 

 

 

 

 

 

 

 

When you have assigned the renovation Now that we have assigned Elements in our 

project to the correct Renovation Status we can save Views using these Filters to 

produce our Documentation. 

 

Heres an example of where certain views will come in useful: 

 

Existing Plan use the Filter 01 Existing Plan 

Existing Elevations use the Filter 01 Existing Plan 

Demolition Plan use the Filter 02 Demolition Plan 

Proposed Plan use the Filter 06 Proposed Plan 

Proposed Elevations use the Filter 07 Finished   

 

Renovation status can equally affect 3D Views to communicate the project to the client 

through the construction phases, and can be saved the same way. 
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Layer Matrix   
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Pens 

All Pen Sets are based on the ArchiCAD International Standard and are divided into 3 

main sections; the  pens (1-140), the  Pens (141-180) and the New 

Zealand Pens (181-194) which are to aid with drafting & traditional workflows. 

The first 180 pens are standard ArchiCAD pens specific to the Tools, each column is a 

tool and each row is for a certain function. Combined they result is a very structured 

format which is best explained in the diagram below. Generally the first 180 pens are set 

correct for the scale of the output.  

 

Then we have the new  in two horizontal rows; the top row 

being the  & the bottom row being the  pen. 

 

 

Then we have 4 rows of : 

10 – colour & description describes pen weights no matter what scale you 

print from 0.001 to 3.0mm. 

10 – different shades of grey (5%-90%) that are grey even in the 

Printing Pensets and all set to a thickness of 0.1mm. 

A single red , for adding Revision Clouds using Change Tool and 

markups. 

2 ‘ , one thin (0.25mm) and one thick (1.0mm), designed to use when you 

want to remove a rouge line that you cannot by modelling. 

10  – these are set to colour even in the Printing Pensets & all set to 0.1mm. 

And 9 , 3 for each – Existing, Demolition and New 
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Shortcut Keys  
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